Error when doing TOPS Coregistration - NodeId: Back-Geocoding

Hi! I’m trying to do TOPSAR Interferometry.

When trying to coregister (with the Radar>Coregistration>S1 TOPS Coregistration>S-1 TOPS Coregistration tool) two different images I get the following error message “Error: [NodeId: Back-Geocoding] org.jblas.Nativeblas.dgemm(CCIID[DII[DIID[DII)V”.

Not sure what I’m doing wrong. I’m following the TOPSAR Interferometry tutorial

I’m able to view the products and I haven’t done anything to them. Am I supposed to do anything to them before I try and coregister?

can you name the two products?

S1A_IW_SLC__1SDV_20180921T162932_20180921T162959_023799_0298A6_7225.SAFE and S1B_IW_SLC__1SDV_20171009T162030_20171009T162057_007755_00DB1D_E36E.SAFE

They are a year apart but that shouldn’t be an issue, should it?

The temporal baseline might not be a problem but it is better to have two images of the same track
Especially if you want to proceed with interferometry, this is strongly required because of the perpendicular baseline of the two images which becomes too large if images of different track are used. Also the incidene angle under which the common area is illuminated is too different.

Your S1A image is track 150 while the S1B image is orbit 51.

Have a look at this illustration: INSAR / DINSAR - Perpendicular baseline calculation

1 Like

Looks like this is a bug in the sense that there should be an error-message saying TOPS-coregistration (and other co-registration methods) only work with images from the same track. @mfitrzyk @lveci


I got the same error message even when using two images from the same track.

So I followed the answers in this post Problem with Back Geocoding of TOPs files for a linux system and installed libgfortran3 (via sudo apt-get install libgfortran3).

TOPS Coreg now works as it should and the problem is solved.


I also received this kind of error recently, I just opened Snap as an administrator in windows (I clicked Run as administrator) and the error was fixed even without installing libgfortran3.


Hi everyone,
I have the same problem. We installed the " libgfortran3" but I still get the same error massage.
The images are from the same track, and I use Linux system. The same data, and the same SNAP version on the Window system works without problem!
Has anyone any suggestion how I can overcome this problem in the Linux system?
thanks in advance,

Hello everyone,

I am also having this problem now. I just installed the version 8 of the SNAP. This problem did not occur when I had SNAP 7.0. I also installed libgfortran3 but no improvement. Can someone help?

Thank you!

can you please also install libgfortran5, this has reportedly solved the issue here: Please test the SBAS_snap2stamps

The issue is still there. This is the error:


Thank you

Thanks @ABraun for the suggestion. unfirtunately the installation of the libgfortran5 didn’t help us, and we still get the same problem. Open to suggestions :slight_smile:

@lveci @jun_lu do you have an idea?

Hi Anahita,

Did you solved the problem, because I am facing the same error even after installing libgfortran5? If you solved the problem, could you please share the solution?


HI, unfortunately, the problem didn’t resolve!
I did however install Ubuntu on another computer (which I have admin right!) and installed SNAP, everything works properly!
Sorry, I can’t help much here!
Best regards

Hi everyone,

Thank you for your time @Anahita. If someone has any solution please let me know.


In case you are using Linux, please check this FAQ entry: On Linux I get the error org.jblas.NativeBlas.dgemm(…

1 Like

Hi everyone,

I am facing a problem while doing back-geocoding of coherence, I use pyrosar and even though I installed libgfortran5 package for performing back-geocoding based on this link. I am getting the following error.

It was working few weeks ago. But now I get this problem. Please let me know the full requirements for the back-geocoding. Whether it needs any special package installation or any special permission? looking for the reply.


I merged both topics, because they deal with the same problem.

Dear ABraun,

I don’t find any particular solution for this error through the link that you provided. whether it depends on S1 toolbox? Because I am getting the xml workflow but the problem is with back-geocoding. If others have solution please share it.