Error when runing Stamps(2,2)

Hello,everyone. Recently,I got a problem when I ran stamps on matlab2018a in linux20.04. the specific issue is that when i call stamps(2,2,), matlab shows that:<Error using signal.internal.sigcheckfloattype
Can’t load ‘/home/yzq/apps/matlab/R2018a/bin/glnxa64/libmwdastudio.so’:
/lib/x86_64-linux-gnu/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

Error in signal.internal.sigcasttofloat (line 36)
signal.internal.sigcheckfloattype(x,’’, fcnName, varName, datacheckflag);

Error in gausswin (line 40)
a = signal.internal.sigcasttofloat(a,‘double’,‘gausswin’,‘ALPHA’,…

Error in clap_filt (line 47)
B=gausswin(7)*gausswin(7)’;

Error in ps_est_gamma_quick (line 225)
ph_filt(:,:,i)=clap_filt(ph_grid(:,:,i),clap_alpha,clap_beta,n_win0.75,n_win0.25,low_pass);

Error in stamps (line 326)
ps_est_gamma_quick(est_gamma_parm);>
I searche on forum,but have no result about this issue, this things have been bothering me for days.I try some ways to fix it but still not work. So I hope someone can help about this.

This is a Matlab error, so you should be asking for help on a Matlab forum. In this case, google “matlab undefined symbol: FT_Done_MM_Var” finds an answer from Matlab tech support.

1 Like

You are right! I thought it was An error about stamps.turns out it is a matlab library problem ,I go search on matlab forum you recommended and finally fix it .Thnak you so much for giving me advice!!!

Glad Matlab’s answer worked, and it could help others who also suspect the problem is with stamps to have your report here.

Hello zhiqiang513,

i just facing the same error. Please, how did you fixed?

Regards,
Othmane.