Error while using Batch processing

I have been using the Batch processing tool a lot lately to pre-process Sentinel-1 data.

I have now run into an Error message that I do not understand. When I try to populate the Batch tool with the Sentinel-1 files it gives me the following error: “Error getting product entry: unable to connect to database Database ‘productDB’ not found.”

Has anybody encountered this before and knows how to resolve it?

Thanks in advance for your help


Where are your products stored in your computer? Do you have the same issue if you open them in SNAP and then use the Add oppen products icon?



thanks for taking the time to reply to my question.

The products are stored on an external hard drive. I have used products stored here in the past for this exact process and it never was a problem.

I have tried adding them directly and first opening them in SNAP and then adding them.


I’ve seen this message on the command line. Actually every time I process something. But I did not noticed yet that it indicates any real error. It is more like a false alarm. But if it is shown in the GUI it is a problem.
Maybe @obarrilero can have a look at this?

I haven’t seen this before, but analysing the code I have seen that it could be related to a corruption of the database that is created inside the .snap folder. Could you please try to delete the productDB folder in your .snap directory and re-try it?

The productDB folder does not exist. Maybe that causes the problem in the first place?

It should be created automatically by SNAP. Do you have write permission on the folder? Have you changed anything in the SNAP configuration files?

I have not changed anything in the SNAP configuration files.

However, I did not have writing permissions on the folder. Changing this was not possible. I have now re-installed SNAP.

It now works fine again.

Thank you for your quick help!

I got this same error. I was previously getting a Java Heap Space error and following the advice from another thread changed the size of my cache file. After that I kept getting the error discussed above but thanks to @obarrilero, deleting the productDB folder worked.