Error with GPT: external tool adapters

Hi there,

Since joining this forum, I have been happily using SNAP desktop on Windows 7 x64 for my Sentinel-1 requirements.

However, after updating SNAP engine and the S1TBX plugin to their most recent version (5.0.3 for both), trying to use GPT on my custom graphs returns either null outputs or errors. In my logging, I receive the following error: “SPI not found for Operator ThermalNoiseRemoval”. The same processing graph works fine when run manually in SNAP Desktop, so I believe there is some issue with GPT.

When I tried to run GPT without any arguments, I receive the following error:

This confused me greatly, since it appears to be looking for S2TBX which I disabled/uninstalled months ago since it is not relevant to my needs. Also why does GPT need this GDAL installer when the graph operators worked just fine without it mere weeks ago?

I have tried to “repair” the existing installation using the SNAP 5 Desktop install executable (can’t reinstall because I don’t have local admin privileges), but it had no obvious effect. Is my only recourse to completely wipe my system of SNAP and start over? Any advice would be greatly appreciated.

Actually this should not happen. @kraftek, @ramona_manda can you have a look at this, please?

Maybe it will help you if you remove a SNAP system directory. In the adressbar of the windows File Explorer enter %appdata%/SNAP. Remove all its content. Probably it will work again.
You will need to updated SNAP and S1TBX again afterwards but the S2TBX modules should be gone.

Thanks for the note, Marco.

I removed the contents of %appdata%/SNAP/ and rebooted my machine. After restarting, I opened SNAP Desktop to update (as suggested) and was notified that the following plugins needed updating:

Despite seeing the Sentinel-2 Toolbox category, I downloaded and applied these updates. I then restarted SNAP Desktop and was greeted with this message:

I clicked “Disable Modules and Continue” and manually tested my custom graph to ensure that it still worked (it did). With that success, I tried to run the same graph (adding file parameters $input_file and $output_file in the Read and Write operators of the graph xml) via a command line call to GPT. Unfortunately, I am still getting the same error as shown in my first post.

It seems the installed modules got somehow messed up. Probably it is better to reinstall SNAP without the S2TBX. I’m sorry for this, but it seems to be the best solution.

Fair enough. Thanks for the follow-up!


I investigated the issue and it seems to be caused by an attribute in versions 5.0.0-5.0.3 that prevents some S2TBX modules to be uninstalled (so must probably some S2TBX modules, such as gdal module, were not actually uninstalled). Unfortunately, there is no other solution just to uninstall SNAP, and as Marco said to install it without S2TBX. Let me know if this fixes your issue.