Error with SNAP tool S-1 Back Geocoding (Linux Ubuntu 17.04)

Hi all,

I have a problem with SNAP tool called S-1 Back Geocoding tool for two images that I need to use for interferometry.
The program shows me an error that doesn’t allow me to continue with the process.
I am starting to work in SNAP with system Linux ubuntu 17.04

I am going to show what the error says:
Error: [Nodeld:Back-Geocoding]org.jblas.NativeBlas.dgemm(CCIIIID[DII[DIID[DII)V

I need help, thank you.

please have a look at this FAQ entry:[DII[DIID[DII)V

Good day ABraun

Link didn’t open, I don’t know why
Can you explain how to solve that error, please?

Thank you!!

On Linux I get the error org.jblas.NativeBlas.dgemm(CCIIID[DII[DIID[DII)V

On Linux the JBLAS library needs a Fortran dependency installed

sudo apt install libgfortran3

In some cases version 5 is also required

sudo apt install libgfortran5

The SNAP FAQ is linked from this forum FAQ page - linked above… easy to find :wink:

1 Like

Thank you / Gracias Cristiano Lópes.
Very kind for the information / Muy amable por la información.

Hi ABraun,
I have installed libgfortran5 and libgfortran3, but it still doesn’t work. Should I reinstall SNAP after installing libgfortran5 and 3?

Could be worth a try - do you get the same error message?

yes,the same when back-geocoding.Thanks a lot, I will try it

it works when I reinstall SNAP, thanks a lot!

1 Like