ERS-Topographic Phase removal-SNAP

I have this error message

in Topographic phase removal, when I process two ERS2, SLC images ( SAR_IMS_1PNESA19950613_204808_00000018A001_00415_00770_0000.E2 and SAR_IMS_1PNESA19950718_204810_00000018A002_00415_01271_0000.E2), in order
to produce an interferogram. I have installed SNAP 5.0. Before Topographic phase
removal, I followed these steps:
1.Apply orbit file
3. Interferogram Formation

Is there any solution to this problem?
Thank you in advance!

is your data located outside the SRTM coverage?

Image source

It is inside the SRTM coverage. It is an area in Greece.

Try SRTM 1Sec (Auto Download) instead.

I tried SRTM 1 sec(Auto Download), but I still have the same error message.

does your interferogram look alright?

It is not good. There is a lot of noise and some fringes due to topography.

thank you. Can we please also see the coherence image?

Also not good. I perform DEM Assisted coregistration with Xcorr and
I tried different combinations in coherence window sizes(range/azimuth, 1/5, 2/10,5/5,10/10),
during the interferogram formation. At this example I used the combination
range 2, azimuth 10.

Values of low coherence are caused by decorrelation. I guess these areas are covered by vegetation. So even the temporal baseline of 35 days is already too long for good interferometric patterns.

But this doesn’t answer your Phase removal problem.
are i and q parts of your images still in the InSAR stack?

Yes there are
Here is the i band

and here is the q

one thing you can try is to download another DEM from a different source, for example the ALOS World DEM:

Then you can use it as an external source for topographic phase removal.

I used an external DEM from the link you provided, but still
I have the same error. This happens only with ERS data. I didn’t
have the same problem in the processing of Envisat or Sentinel data .

that’s strange and i must admit that I don’t have a clue what could be wrong. Have you tried running this on another computer?

I have tried the same processing steps with the same dataset on
different computers with different OS(Ubuntu, Windows,MAC), with
the same error. I attached the full error message. Is there maybe a
different approach for producing interferogram using ERS data in SNAP?

error_message.txt (3.4 KB)

I tried to download the images you named in the first post to try it myself but couldn’t find them in the EOLiSA system.

Yesterday there was a maintenance activity in EOLiSA catalogue and ERS data
were not available . Maybe that is why you couldn’t find the data I am using. I searched the catalogue today with your search criteria and I didn’t have a problem.

thanks for comparing. I first received an error message which realated to the ERS issue. Later i just received empty results. But now I see the products again and will try to reproduce your error.

why are the sea areas masked out in your images? Did you alread apply Range Doppler Terrain correction?

I used DEM Assisted Coregistration and I checked the option
Mask out areas with no elevation.