Exciting news –SNAP10 version release!

Could you provide more details regarding the issue, such as the product names and processing steps, so that we can reproduce the issue? Thank you.

Hi All,

Just bumping this earlier issue - SNAP still cannot access lots of my file system and, despite investigating access rights, I can’t find any reason why this is the case.

Hi Ben,

a similar issue is reported here: No JFileChooser Documents/Desktop/Downloads access prompt in macOS 10.15 Catalina · Issue #85 · tofi86/universalJavaApplicationStub (github.com)
The content of the directories is not shown because the prompt “[app] would like to access files in your Documents folder” is not shown.
Maybe you can work around by following this guide:
macos - Add apps to “Files and Folders” permissions?

Some Java background:
I just learned that using the JFileChooser (which SNAP uses) is discouraged. One should actually the FileDialog, but this has other issues.
I’ve also read that Apple rejects Apps from the App Store, if they use the JFileChooser.

Mac always needs an extra pat pat :slight_smile:

1 Like

This seems to be the reason for this. When opening first only a single product, I can open the two simultaneously afterwards.

Thank you! I’ve updated the existing JIRA ticket (SNAP-3637) with your error.

Perhaps related…the file /.install4j/response.varfile still has the names of the old toolboxes in it:

# install4j response file for ESA SNAP 10.0.0
sys.programGroupName=ESA SNAP
1 Like

So SNAP 10 is working well for me so far. Awesome!
Is there a way to get around these warnings?

OpenJDK 64-Bit Server VM warning: Option AggressiveOpts was deprecated in version 11.0 and will likely be removed in a future release.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.netbeans.ProxyURLStreamHandlerFactory (file:/esa-snap/platform/lib/boot.jar) to field java.net.URL.handler
WARNING: Please consider reporting this to the maintainers of org.netbeans.ProxyURLStreamHandlerFactory
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
1 Like

Dear all,

I am also very happy about the new version of SNAP, however I am
already run into a problem with the unwrapping using SNAPHU. i know the
SNAPHU is an externa tool, however I would like to understand why I
cannot retrieve a proper unwrapped phase.

The first question is:
Is the snaphu 2.0.4 version compatible with SNAP 10? In the Standford
website (SNAPHU) they
write about the new version 2.0.7, which however cannot be downloaded or
installed though SNAP.

The second questions is:
Why the unwrapping does not work properly? Apparently it does not unwrap
the positive phase (uplift), which is actually masked out. I have used
the same dataset I have previously successfully processed with SNAP
9.0.0, using SNAP 10.0.0 with the same SNAPHU version (2.0.4) and these
are the results:

We are carrying out a master thesis and this suppos a huge problem for
us. Please could you help with this issue?

I am sorry I can’t be of more help, but as far as unwrapping phase for DEMs goes, Snaphu 2.0.4 seems to be working properly for me in SNAP10.

Hi Marco,

That certainly does seem to be the issue, but I wasn’t able to find a solution. I can’t add anything to the “System preferences > Privacy > Files and folders” list (another Mac issue, apparently), so I tried to add SNAP, to “Full Disk Access”, but with no luck. I activated the OSx console to get some better logging info, and this gives me an error associated with:


I tried to give that Full Disk Access, but again without success. I have found a few other posts about rebuilding JAVA, but I’m not willing to go down that road! I think, for now, I am just stuck and this perhaps stands as an outstanding issue. Do you happen to know if an upgrade to Sonoma would fix this?

I upgraded to Sonoma and now have access to the Desktop, Documents and Download folders. Thanks for the support, as usual! :slight_smile:

1 Like

Hi @khalidtijani,
The Sen2Coral team has been notified about the plugin’s incompatibility with SNAP 10.