Export geometry to shape file

It worked perfectly. Now I get the error message before saving: Can not export geometry. …whose geometry type is class com.vividsolutions.jts.geom.Geometry.
Projection is correct (see properties) but that format of the geometry is not accepted.

Exporting Pins and GCPs to shape works well. Many thanks for the fine service.

I have now reinstall SNAP5.0.0 - running with no later updates: and it works. Hence a bug has been introduced later.
Also at a certain moment (!) renaming a file is no more possible, e.g. using Band Math - “new_band_1” into something meaningful.

I have the same problem when trying to export the vector geometry I created into shapefile. I am trying to classify sea ice types and draw training data on the Image using the vector tool. I want to export these vector data into a shapefile format and the message I get is:
“cannot export geometry whose geometry type is class com.vividsolutions.jts.geom.Geometry.”
My training data are shown in the image below

When I tried to open up the vector file by right clicking on the vector file -> open placemark window, the geometry was empty.

So, is it a bug that appeared when updating the SNAP as jlichten mentioned? I remember, some time ago I could export my vector files into shapefile without any issues.
I am running the SNAP version 5.0.5


Same problem with 5.0.6

Edit: And also returning to 5.0 solved it, so I guess @jlichten is right.

I’ve just released 5.0.7 modules. Should be fixed now.