Exported table of pixel values under pins are different from values in spectrum view

Hello, when I tried to extract values under some pins, the exported table data as well as curve ranges in MS excel are different with spectrum view in SNAP.
Don’t know what reason is it ? And which one should be the correct ?
Thank you ~


Could you use the same color codes in both? I think they look pretty much the same until 900nm, but I am confused with the colors. Try to establish the same range in the y axis. Maybe you can check which columns you use in each case?

I’ve checked the exported flat text data, and found values are same as pin manager table.
So the problem goes to this:
The values in several bands are quite different between pin manager table and spectrum view axis range. See red rectangles marked below. Is this due to the auto adjustment by SNAP ? The spectrum view only gives an exaggerated appearance ?
Thank you ~~

I think you are showing your pins and also moving around the image with the cursor, right? (I assume the black line is the moving pixel). When doing so, press the shift key for the plot to adjust to the values.

moving cursor position function is off for the spectrum view.
The values for pins at band 1 are apparently much higher than 0.1 while the extracted data in table all lower than 0.09.

The black line is for a fixed position and its value at band 8 (842nm) is 0.053, but there is a peak over 0.325 in the curve view.

I tried with a resampled S2 L1C and it looks ok in both plots.I am not sure what can be your problem.

Thank you for the test result.
I also checked S2 L1C data of the same scene.
Unfortunately, there is still this bug. Color setting has been the same in spectrum view and MS excel and they show different shapes.
Curves in SNAP view exceed 0.2 at several positions but data values are all lower than 0.175.

A new phenomenon: same pin position shows different curve shapes for pin data and moving cursor.
DOES anyone encountered this problem before ??
Remark: moving cursor now is just at pin 3 pixel.

I haven’t heard about this problem before.
I see that you are still using an old SNAP version. Maybe the problem will be gone when you get the latest version and install the latest updates.
SNAP Download – STEP (esa.int)

This is how it behaves for me:

Both spectra are the same.

Thank you very much !
After I updated the SNAP version this bug has been fixed :smile:

1 Like