Extract processed band as GeoTiff

I have calculated LST and has it as a band inside the product of format .dim file and want to save it as GeoTiff outside the .dim as independent band. However, for some reason SNAP does not let me do so.

getting the following error:

I have done resampling on the bases on the thermal band and did not work as well.
What could be the solution to extract a single band saving it as GeoTiFF outside SNAP?

After a resampling this message should not show up anymore. Maybe something went wrong?
But you can create a subset in which you only include this band and then do the export.

It still does not let me since I selected the complete layer I wanted to save as GeoTIFFwith the visual selection tool and only selected the desired band LST_cels and this message appears:

The original data is Landsat 8 and I calculated LST and saved all the steps in the same .dim file.
Could this be the reason?
Thanks a lot.

I just tried to create a subset wit h a generated band. It worked with out a problem. Without resampling upfront.

So, just a few more questions.
The message above seems to indicate that you are using a valid-pixel expression which references all the other bands. Is that true?
Without knowing the data, it is difficult to make a diagnosis.

Is it possible for you to provide me the data?
I’ll send you a PM with a location where you can upload it.

It is as I thought. The valid-pixel expression of the band references the other bands.
I guess you created first Virtual bands and then converted them to “real” bands, right?

That’s also the reason why opening this band takes so long. All other bands have to be loaded too.

You can now change this expression by right-click on the LST_cels band and open the properties.


delete the expression.
Instead you can use an expression like LST_cels > -500.

Then you should be able to export the band.

For the future you can use the option to not create a virtual bands with the Band Maths.
Just uncheck the “Virtual …” option.
image
I think this way the expression will not be a problem. Alternatively, you manage how the valid-pixel expression evolves when working virtual bands.

Helo Marco,

I changed the expression as you mentioned:

it required resampling ,

which I did it, and save some resample file, but does not let me open it neither in SNAP nor in QGIS…

I just tried it a and did the following steps

image
2.
image
Answer for the following question if flags shall be included “no”
3.
Export this to geotiff.
image
And it is working.
image

And resampling worked like this:
Note as target format I’ve selected GeoTiff-BigTiff. Just in case the file might get to big for std. Geotiff.
image


I’ve have cancelled it because it took very long. Also because of the references of the other bands in the valid expression. But I got no error…

When working again on a landsat8 product you can resample it as the very first step or you just remove the panchomatic if you don’t need it.

The exported LST_cels GeoTiff opened just fine in QGIS.

1 Like

Hello Marco,
It worked very well with the formula LST_cels > -500 and the subset after that I could export and open in QGIS.
Thanks a lot!!
PD. a question: for avoiding this next time I have subset before processing the bands leaving the panchromatic outside the new subset ?
Thanks a lot again.
Regards,