Foolproof manual esa-snappy installation?


I’m having an issue with the esa-snappy installation, the same as discussed in Error while configuring esa-snappy with Python 3.9.13 on Windows 11 - Configuration Failed - No Error Code.

I’ve tried to remove all the files from previous installations and made completly new SNAP 10 installations on two different devices (one with Windows 10 and the other with 11). Both installations have been attempted with different Python versions (Anaconda 3 environments with Python 3.6 and 3.10). I’ve made sure that there wasn’t any PYTHONPATH or PYTHONHOME on the system variables.

It seems that for some users this worked, but I’m still getting the same error messaje and I’m incapable to install esa-snappy.

I’ve followed this guides:, Configure Python to use the SNAP-Python (snappy) interface (SNAP versions <= 9), Configure Python to use the new SNAP-Python (esa_snappy) interface (SNAP version 10+); but none have helped me solve the issue.

On previous attempts, I manually installed JDK 8, Maven 3, and successfully installed JPY, but the esa-snappy (‘snappy’ on SNAP 9) configuration was faulty and had problems using the Sen-ET plugin, resulting in the following error message:

C:\Users\Andrea\AppData\Local\Temp>“C:\Users\Andrea.snap\auxdata\sen-et-conda-Win64\sen-et-snap-scripts\…\python.exe” “C:\Users\Andrea.snap\auxdata\sen-et-conda-Win64\sen-et-snap-scripts\” --biophysical_file “C:\Users\Andrea\Desktop\PRUEBA SEN ET!OUTPUT_biophysical!.dim” --output_file “C:\Users\Andrea\Desktop\PRUEBA SEN ET!OUTPUT_biophysical!processed.dim"
Traceback (most recent call last):
File “C:\Users\Andrea.snap\auxdata\sen-et-conda-Win64\sen-et-snap-scripts\”, line 4, in
import snappy_utils as su
File “C:\Users\Andrea.snap\auxdata\sen-et-conda-Win64\sen-et-snap-scripts\”, line 12, in
from snappy import ProductIO, Product, ProductData, ProductUtils, String
File "C:\Users\Andrea.snap\auxdata\sen-et-conda-Win64\sen-et-snap-scripts......\snap-python\snappy_init
.py”, line 317, in
Product = jpy.get_type(‘org.esa.snap.core.datamodel.Product’)
ValueError: Java class ‘org.esa.snap.core.datamodel.Product’ not found
Process exited with value 1
Finished tool execution in 22 seconds

I’m not sure if there is something wrong with the Python-Java bridge.

Is there a foolproof way to manually install esa-snappy?

I would be thankful if you could help me.

Best wishes,