GCP Manager Error: 'Not enough (valid) GCPs for selected method'

I’m using SNAP and I’m grateful for the opportunity.
In the GCP manager screen, I encounter an error message “Not enough (valid) GCPs for selected method” under “Status:” for “Attach/Detach GCP geo-coding.” Could you please provide a solution for this issue?

Specifically, the problem is that after placing GCP “+” marks on the map in SNAP, when I launch the GCP manager and make fine adjustments to the latitude and longitude values in the table, the GCP “+” marks on the map do not move accordingly. Also, I suspect the above error message is the cause as I can’t perform GCP geo-coding attachment or detachment.

OS: Microsoft Windows 10 Home
Version: 10.0.19045 Build 19045 (Japanese version)
SNAP version: 8.0.9 (I also tried version 9 with the same error)
I also have Sentinel-1 Toolbox installed.

Thank you for your attention.
Best regards,

Hi Blueeast

When you define a GCP based Geo-Coding the geocoordinates are calculated by polynomials.
The number of GCPs you need to select depends on the selected polynomial degree (method).
For the “Linear Polynomial” you need to provide three GCPs, for the “Quadratic Polynomial” 6 and for the “Cubic Polynomial” 10 GCPs.

It is intended that the marks on the image don’t move when you are changing the geo-coordinates of a GCP. You actually define the reference geo-coordinate. You select the image coordinate and say which geo-coordinate it should have.
If the image coordinate would move along with the changes of the geo-coordinate, you wouldn’t set a reference.
You need to change the X- and Y-values. You can either do this in the GCP Manager table or by dragging them around on the image with the selection tool image enabled.

Hi Marco_EOM,

Thank you so much for your help and detailed explanation regarding the GCP manager in SNAP. I really appreciate your support.

What’s important to me is the ability to precisely place a “+” mark on the SNAP image at specific latitude and longitude coordinates. To achieve this, I will activate the GCP tool and move the cursor on the image until the latitude and longitude displayed at the bottom of the SNAP screen match the desired coordinates perfectly. Once I find the perfect spot, I will click to place the “+” mark.

Thanks again for your valuable assistance!
Best regards,

Good to know that I was helpful. But still, I don’t get your use case.
If you add the GCP at a specific geo-coordinate and create a GCP Geo-Coding from those the Geo-Coding will not improve compared to the already existing. Because you are not changing the geo-location of the marks in your scene.
Maybe you can explain what you want to achieve.

"My aim is not to create GCP Geo-Coding but to precisely place a “+” mark at specific latitude and longitude coordinates. By doing so, I can track the flow of glaciers. For vast glaciers, there are no fixed points on the Sentinel-1 images, making it difficult to understand how the glacier is moving. That’s why I want to accurately mark specific latitude and longitude points on the images to track the glacier’s movement and gain a better understanding of the geographical information.

In this case, I think that the Pins suit your needs better. They behave as you expect it.
If you don’t like the pin styled icon you can switch to something else.
Open the Layer Manager and the Layer Editor. Select the pin layer and then you can edit styling of the pins.

"I have decided to use the pin tool to accurately place a “+” mark indicating specific latitude and longitude coordinates. Additionally, I intend to label the pins with latitude and longitude displays such as 133°W/75°S. However, I have encountered a problem with SNAP, which I would like to report.

First, I use the pin tool to place pin 1 on the SNAP image. Then, I change the style of pin 1 from ‘symbol: pin’ to ‘symbol: plus’ in the Layer Editor. However, the actual style remains as shown in the attached image, where the pin’s tip has a “+” mark added, and the pin itself remains visible. In other words, both the pin and the “+” mark are displayed.

However, when I place a second pin and open the pin manager, a table is displayed for both pins. If I select the second pin, the style of the first pin’s mark changes to just the “+” mark, and it becomes normal.

Therefore, it seems that the only way to remove the mark from the pin’s style is to place two or more pins and switch control to the second pin. As long as control remains on the first pin, I cannot remove the pin’s mark from its style. At that time, I was unaware of how to remove the pin’s mark, so I used the GCP tool to place the “+” mark instead.

The two main issues seem to be:

When there's only one pin, I cannot remove the pin's mark.
The method of changing the pin's style using the Layer Editor is not described in the Help manual. It only mentions using the pin manager and the edit dialog to make changes, but specific steps are not provided.

As a result, it seems that it is not possible to use the pin tool to place only the “+” mark as intended. That’s why I opted to use the GCP tool instead."

If you have any further questions or need clarification, feel free to ask.

Yes, this is true. The Pin shape which remains after switching the symbol is actually the highlighting which indicates the selection status. This is a bug in SNAP.
It is unfortunately not possible to change the default symbol so this needs to be done for each product again. And yes, the help on this topic could be improved too.