Geocoding in PolSARpro

When i used the polsarpro(5.1 version) to deal the ALOS-2 data(L1.1CEOS) at the

i don’t know how to resolve this question .
Also,when i used the polsarpro(6.0 version),click the Sentine-A/B mission,and after the enter,it show the Error:can`t read 'widget(PSPEDUCI).

So,if anybody konws how to deal with this problem,please tell me ,thank you !

the first problem is

Just to go sure - is your study area outside the SRTM coverage?

Have you tried downloading the corresponding DEM and using it as an external DEM?

I do not know this in your case, but Geocoding (including multi-looking) should not be the first step, because it drastically changes the scattering properties of the actual pixels

Thank for your answer,
First, I use the San Francisco (Nov. 11, 2009 and Aug. 21, 2018) Stripmap,the Sample Product.I think it may not outside the SRTM coverage.And i would try downloading the corresponding DEM and using it as an external DEM.
Second,before the Geocoding process,i have done the extract polsar images and when i used the Utilities->SNAP-S1 TBX->Geocode[T3]matrix,in this processing procedure ,it show the problem,(A PROBLEM OCCURED DURING THE GEOCODING)

ok, San Francisco is covered, but maybe your firewall blocks the retrieval of the SRTM. Try downloading it manually and select “External”.
Maybe this already solves the error, please report.

Thank you ! :slight_smile:

Hi, I am also facing the similar case. “A PROBLEM OCCURING DURING THE GEOCODING”. I just downloaded the external dem, and doing again, but somehow the result still same. Anybody can help?

Is PolSARpro correctly linked to snap64.exe?

Maybe your data lies outside the SRTM coverage?

1 Like

Hello Braun and polsarpor guys,
I have also met this problem : A problem occured during the geocoding.
POLSARPRO correctly linked to snap64.exe, and has been updated to S1 tbx 8.0.3.

Ten minutes ago, Polsarpro Geocoding in the same study area could still be done. However, now it is wrong. Is this my software problem or SRTM? It is reasonable to say that SRTM should have been automatically downloaded at the last successful geocoding.

please check if there are incompletely downloaded SRTM tiles, at best by deleting the aux folder as described here: A process related to digital elevation models is taking forever to finish

You can also check if the SRTM data is correctly downloaded in SNAP (then the problem is with PolSARpro or the bridge to SNAP).

Hello Braun,
Great thanks for your reply, I have checked the incompletely downloaded SRTM tiles. I have cleared all tiles of the SRTM 3arc folder. When running geocoding, the SRTM does not download automatically, and then show the same error : a problem occured during the geocoding.

I don’t know the reason then, sorry.
Is it an option to import the PolSARpro files into SNAP and geocode them there?

Hello Braun,
Great thanks for your help!!!
I try to import the PolSARpro files into SNAP, yet the svm classification result can not been imported into SNAP. I guess, the svm result is not SAR file, so it can not import.

I will wait a few days, may be related to the Internet.

Great thanks for your continued help!
Best regards.

please check hof PolSARpro files are loaded into SNAP in this video: (starting at about 17:20)

OK!Great thanks for your patiently reply. I will check it carefully.