Getting "error in opening zip file" for DEM during range doppler terrain correction

Hi, everyone, I get an error message of “error in opening zip file” for DEM during range doppler terrain correction with newst SNAP 7.02.

I have checked that the zip file has been successfully downloaded, and I can unzip it sucessfully, while SNAP try to download it for one time and another, finally it give an error infomation.

I have even download the zip file and put it in the .SNAP folder manually following the suggestion learn from the forum, however, SNAP seems ignore the existed zip file and still trying to download a new one.

Any suggestion?

Thanks.

What kind of DEM is it and where did you download it? The dem folder only accepts certain file structures and names.

I have tried SRTM 1sec, SRTM3sec, ACE30, they are automatly downloaded by SNAP successfully, however, they all have the same issue about repeat downloading and overwrite. While it seems a bug of version 7, since it works with SNAP6.0. Now I have solved this problem by using SNAP6.0.

I think there is another way for me to work around. One of the feature of SNAP7.0 is “Allows disabling the automated access to remote auxiliary data”, would you please tell me where is the settings for SNAP7.0 not download automated (I will prepare well all the orbit and DEM ZIP files from SNAP6.0)?

I just had a look and did not find the option.@marpet do you have an idea?

Indeed there is a new property which shall allwo disabling the remote access to aux data, but I’m not sure that it is yet used everywhere.

This name of the property is snap.gpf.allowAuxdataDownload. It can be added to the snap.properties files which is located in the etc folder of the installation directory.

snap.gpf.allowAuxdataDownload = false

For DEM files you can configure the auxdata.dem.properties. Also in the etc folder.
For example you can specify the property AuxDataPath. Then the DEM file will be stored there and also this location is checked if the necessary DEM file already exists. e.g:

AuxDataPath = c:\\myDemFiles
demPath = ${AuxDataPath}/dem
2 Likes

Thanks for the information. That’s what I’m looking for.
If the DEM is manually copied to the auxdata folder (.snap\auxdata\dem\SRTM 3Sec), is the AucDataPath still required to be specified?

No, if you fill the directory in .snap\... then it should work.
But it is beneficial to have the DEM files at a different location. Then the files are not accidentally removed when SNAP is uninstalled.

Although your idea is clear, I am sorry to report that it does not work in my computer for closing the auto download option.
Originally there is no parameter of snap.gpf.allowAuxdataDownload in snap.properties file, I have just add a new line as below:
snap.gpf.allowAuxdataDownload = false
But when I run gpt, it still try to download DEM. I think there may be some issue about my system (win7 64bit), I have run sucessfully only once after I in stall SNAP7.0, but when I run for the second and third times, it always failed with error about unzip DEM files. However, I can still use SNAP6.0, thanks for your efforts on my question.