GPT Command Line for Glacier Velocity

Hi there,
I have made a graph in order to get glacier surface velocity. The graph is working perfectly when run on GUI. I have tried to use GPT to make it running on command line. I have edited the filename as following (master and slave) which can be taken from the command line itself. I have done it for the output as well. Please see the xml file.

test20170615_glacier_velocity_command.xml (5.8 KB)

When I run gpt XXXX.xml, it’s showing I am new to the system, can you please help how to resolve this
test20170615_glacier_velocity_command.xml:1 - Esperando “algoritmo”, encontrado <.
test20170615_glacier_velocity_command.xml:43 - Caractere inválido: “.”.
test20170615_glacier_velocity_command.xml:157 - Esperando “variáveis” ou “início” após declaração de algoritmo, encontrado fim de arquivo (EOF).


Attached is an updated xml file. I turned master and slave into variables.
test20170615_glacier_velocity_command.xml (5.8 KB)

and then invoked it like this:

gpt “G:\EOData\User-Support\test20170615_glacier_velocity_command.xml” -Pmaster=“G:\EOData\SENTINEL\SENTINEL1\S1A_IW_GRDH_1SDH_20140413T034943_20140413T035012_000135_000075_3662.SAFE\” -Pslave=“G:\EOData\SENTINEL\SENTINEL1\S1A_IW_GRDH_1SDH_20140413T034943_20140413T035012_000135_000075_3662.SAFE\”

It didn’t worked for neither. because I have not used the correct input product. But I think it should work for you.

Hi there,
thanks for your help. I run your updated .xml file but still it shows number of errors. Specially when you change the variable like ${master} and so on. Please find it attached.

Oh, you are not invoking SNAP gpt.
It is a different tool which has the same name. Please use the full path to the gpt executable script.

Thanks. Its working perfectly.

Hi, I had the same problem in Ubuntu. To correct the symbolic link to the SNAP’s gpt command, run this (or similar) in your Terminal:

sudo ln -sf ~/snap/bin/gpt /usr/bin/gpt

~/snap/bin/gpt is the path to my gpt command
/usr/bin/gpt is the symbolic link to be corrected.

-sf is used to overwrite the existing link.