GPT Error: ProductSet-Reader - please add a source product


I’ve found a problem with GPT and I’m not sure if it’s being dealt with yet but I cannot find a solution on here.

I have a GPT that includes ProductSet-Reader > SliceAssembly > Write (attached)

This has been working for me for products in 2015/2016/2017, but when I come to use products from 2018, the ProductSet-Reader appears to throw an error (attached)

I have been working on this problem for over 3 days now only to find it seems to be related to handling of the current Sentiel-1 GRD products.

Can anyone tell me what the problem is and what I should do?



1 Like

<graph id=”Graph”>

<version>1.0 </version>

<node id = “ProductSet – Reader”>

<operator> Product Set- Reader</operator>


<parameters class= “com.bc.ceres.binding.dom.XppDomElement”>




<node id=”Slice Assembly”>

<operator> “SliceAssembly”</operator>


<sourceProduct.2 refid=”ProductSat-Reader”/>






{polarization} <selectedPolarisations>



<node id = “Write </operator>

<sources> <sourceProduct refid- “SliceAssembly”/>


<parameters class = “com.bc.Ceres.binding.;dom.XppDomElement”>






I wrote out the code in long hand. The file capture was in Win so I have to go look with linux toolbar, but I think it was a class
define at “Slice Assembly”

In my copy I noticed a comma *typo.


Thanks so much for replying.
I dont understand from your post what you think the problem is, could you explain this to me please.
My code works for products taken before 2018 but not after.

I looked at your code and it is exactly the same as mine, although there are a lot of typos in it so I cant work out if any changes are true or not.


@lveci this could be related to the IPF-update.

Are you using the latest updates 6.0.4? What products are inside $indir?

I tried it with SNAP 5.0.0, 6.0.0 and 6.0.4. I get the same problem with all of these versions.

The products I used inside $indir that didn’t work were these:

Have you tried doing all processing in the internal BEAM-DIMAP format and exporting into GeoTIFF in a separate step? That is the recommended way of using SNAP as other formats can cause strange issues…

Just tried swapping GeoTIFF-BigTIFF for BEAM-DIMAP - same problem with the product set reader:

Error: [NodeId: ProductSet-Reader] Please add a source product

@mengdahl @lveci any additional ideas at all? I wonder if anyone else is able to perform this process with products from April 2018+

Thanks in advance,

Hi Katy, due to the IPF change to 2.90 you must first run ThermalNoiseRemoval before SliceAssembly. Hopefully it helps :slight_smile:

Thankyou for the tip!

I am having trouble using the slice assembly step on tiff files though both in the GUI and in command line. I am getting a ‘java lang null pointer exception’ each time.

If I output the thermal noise removed file as a .dim instead then I get a 'I/O error while reading tie-point grid ‘latitude’

Any ideas?


Doesn’t look like you’re actually inputting a product, that’s why it isn’t reading it. Assuming ‘split’ is a directory? you may have to put a ‘/’ on the end and explicitly write the file name e.g.