GPT.exe does not work on windows 10


I am using in SNAP 8.0 to make some post-processings, such as subset, reproject, l3bin. These operations worked well in old version of gpt.exe in window 10. However, I got errors , indicating the unsuccessful processing.
The warning information was like:

INFO: org.esa.s2tbx.dataio.gdal.GDALVersion: GDAL not found on system. Internal GDAL 3.0.0 from distribution will be used. (f1)
INFO: org.esa.s2tbx.dataio.gdal.GDALVersion: Internal GDAL 3.0.0 set to be used by SNAP.
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/C:/Users/zcao/AppData/Roaming/SNAP/modules/ext/gov.nasa.gsfc.seadas.seadas-processing/org-slf4j/slf4j-log4j12.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/C:/Users/zcao/AppData/Roaming/SNAP/modules/ext/org.esa.snap.snap-netcdf/org-slf4j/slf4j-simple.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
INFO: org.esa.snap.core.util.EngineVersionCheckActivator: Please check regularly for new updates for the best SNAP experience.

I tryied to reinstall SNAP 8.0 but it did not work. The same script did work well in linux ( a virtual machine), I have no idea on how to solve it? Any suggestions are appericiated!


The lines of the log you provide shows normal behaviour.
Can you explain what is not working. At the end you should have got an error message when the processing did not work.

Sorry for missing the end line, that is “Error: Failed to initialize velocity engine”.

This was already reported:

But I have neither a solution for it, nor do I have an idea what could be the cause.

I’ve created an issue for it, so we can track it.
[SNAP-1447] Failed to initialize velocity engine - JIRA (

Thanks, Marco. I have reset my SNAP to v 7.0, all operations work successfully. I guess that this problem was only in SNAP 8.0.


I re install SNAP8.0 and I uninstall the SeaDAS, the problem solved, now all operations work successfully on SNAP8.0.
Maybe there are some connections between SNAP and SeaDAS while using GPT?

@zhigang have you also installed SeaDAS?

Yes, Marco. I also installed SeaDAS 8 and SNAP 8 before. Now, I use SeaDAS 7.5.3 and SNAP 7.0, and they work well.

Did this only happen when both applications were running simultaneously?