GPT IDEPIX Operators

Hi,

After installing SNAP 7 (all toolboxes) and all IDEPIX plugins on Windows 10, I noticed, that following GPT IDEPIX operators are not available to me (by just typing %SNAP_HOME%/bin/gpt):

Idepix.Envisat.Meris
Idepix.Landsat8.OLI
Idepix.OrbView2.Seawifs
Idepix.Probav.Vegetation
Idepix.Sentinel2
Idepix.Sentinel3.Olci
Idepix.Sentinel3.OlciSlstr
Idepix.SuomiNpp.Viirs
Idepix.TerraAqua.Modis

On the other hand I have following (new ones):

Idepix.L8.OLI
Idepix.Meris
Idepix.Modis
Idepix.Olci
Idepix.Olci.Ctp
Idepix.Probav
Idepix.S2
Idepix.Seawifs
Idepix.Vgt
Idepix.Viirs

From others at the office which use SNAP 7 (on Windows 10 and on Mac OS X), all have the operators from the first list available. However, they did not need to install any IDEPIX plugins. One explanation would be that they have upgraded from SNAP 6 and the operators are just leftovers from that SNAP 6 installation.

Is my installation wrong? Or have the operators been renamed and moved out of the standard installation to the plugins? What about the parameters of the operators?

Where can the release notes of the IDEPIX plugins be found?

Any explanations are highly appreciated.

Best regards,
Rolf Scheuner

If you go to Tools/Plugins and click the label “Installed”, you can select the Idepix plugins and look at the version number there. I think I have the latest version installed, from 7.0.0 to 7.0.2, depending on the sensors. I have made several updates and I have both versions on my GPT directory. I am not sure why your colleagues do not have the latest plugins. Maybe they should update to SNAP 7.

Hi Ana, thx for your reply. I have all the newest plugins installed. My colleagues do not have these plugins, because they did not require them so far, because our application still uses the old operators.

I think this issue seems seems to explain what has changed: SIITBX-360

However the SNAP 7 installer seems to not properly remove the modules from previous installations when upgrading from a previous release.

So the solution (on our side) will be to migrate our application to work with the new operators.
The solution from SNAP side should be to fix the installer.

1 Like