Hello everyone .I have a question about gpt .when i run gpt **.xml,which is a graph builder about generating interfergram. and my read is a stack with five slc. when i run it , i check the folder,and get the result,but the process is still running .i dont know why .

and when i want to run all my stacks to generate interferogram i white code like this , but still the problem. i check the folder finding the first stack finished but the process do not show me about this and still running first stack and do not go on with second stack.

Do you have the latest s2tbx update? There was an issue in the previous update which caused the gpt command line not to stop.

thank you for your prompt reply. I think snap is the latest.I download it from SNAP Download – STEP (, and choose the version< all toolbox winX64>

.and if my s2tbx is not latest,how can i check it ? I open sanp check the plugin installer, it shows up to date!

You can select from the menu:
Help / Check for Updates (This is what you did)
Tools / Plugins
And there you can refresh the list of available plugins/updates. This shows you more details.

So it seems you have the latest version. Then the problem has a different cause.

let me check plugin update. btw, i find snap spending too much time for generating interferograms. i only have 24slc, and if i generate all interferograms at once .it seems that snap stop doing work… so i have to separate it and make 5 stacks,even so,it still spend more than 1h to generate 5 interferograms. i have 32G ram