GPT results in no-data value of 0 instead of NaN pixels

I am trying to get a graph running that produces Sentinel-1 GRD backscatter images in decibels. Regions outside what is imaged should get a NaN (in Float32 format), but persistently get a “0”. This is bad, as 0 is a perfectly valid value and should definitely not be used as no-data value. I tried to uncheck the “no-data value used” in the graph, I tried to set it to “0”, but none of these have any effect. Pixels in the exported image are still “0”. Any idea what I can do?

So, no suggestions? Someone put this thread under s1tbx, which I think is a pity since it is a general SNAP issue I face; no data in SNAP becomes 0 in an exported image, no matter the format.

I did not test it but if you look at the metadata file (the dim one), you can observe that there is a Xml tag corresponding to no-data value. Maybe compare this with a generated file created by SNAP-Desktop and a file generated using GPT.


@kristofvt Did you find a solution for the issue you reported?

@lveci @jun_lu can you check if this is still the case?

Could you provide more details (processing chain, product, graph etc.) of your test so that we can repeat the problem? Thanks.