Graph Builder does not allow configuring the Resampling options


I am trying to resample some bands from a Sentinel-3 SLSTR image (Level 1 product) to the spatial resolution of the coarser bands (i.e., bands S1 to S6 to the resolution of F1). As I would like to repeat this operation on several images, I started using the Graph Builder to perform a batch processing. So, I built a simple graph “Read - Resample - Write”. However, when I go to the resampling step in the graph, I cannot define the reference band for the resampling, in the option “By reference band from source product” (the selection ribbon remains empty).

When performed manually (Raster > Geometric > Resampling), out of graph builder, it works perfectly.

I tried on Linux and Mac, with SNAP 8.0. No difference!

I tried with reprojected products and the problem remains.

Am I missing something fundamental?

Thank you in advance for your help!

This is correct an it is a known issue.
[SNAP-614] Reference bands in UI of Resampling operator in Graph builder are not updated when input product is changed - JIRA (

I would suggest that you save the graph you have created and the edit it manually in a text editor.
Maybe it works when you load the modified graph file into the graph builder.

But you can also do bulk processing from the command line.
There is a guide in the wiki which explains it.

Bulk Processing with GPT - SNAP - SNAP Wiki (

1 Like

Thank you very much for the tips!

The bulk processing from the command line and the bash script provided through the link you shared make my life much easier.