Graph builder not working

I’ve been using ESA’s SNAP GUI for basic operations on Sentinel-1 SAR data, I import as a Sentinel-1 SAR Sensor, then I crop (subset) the image to a small extent using geographical coordinates, to later apply a radiometrical calibration, speckle filter and terrain correction. The process is seamless in the GUI, but now I need to repeat the same process for a bunch of different datasets. Hence, I research how to bulk process and found the best way is using GPT, instead of snappy.
I started by generating a XML in graph builder, to use later in gpt, but when I tried to run in graph builder window, it freezes at 29%, can wait an hour and it doesn’t move.

Then I scrapped the graph to a single operation, subset, so it looks like this:


but guess what, it is still getting stuck at 29%, this operation is lightning fast in the gui, so it doesnt makes sense I have to wait more than an hour for it to work in the graph builder,

for completeness:

  • dataset: S1B_IW_GRDH_1SDV_20210723T164429_20210723T164454_027924_0354FB_2090.SAFE
  • Environment: Manjaro Linux
  • SNAP V 8.0
  • Reading tab: under data format I specify the dataset is Sentinel-1
  • Write tab: trying to save as default BEAM-DIM, I don’t think this matters, even a geotiff is failing
  • Subset tab: Im selecting all bands, checking copy metadata, selecting geographic coordinates and using the following to input the boundary: POLYGON((13.8 56.14, 13.8 56.44, 13.6 56.44, 13.6 56.14, 13.8 56.14))

I’ve been trying for a couple of days now, really need help, highly appreciate it in advance.


I just processed this with the settings you have provided, and it worked well for me.
The progress bar jumped also immediately to 29% and then stood still, but after 83 seconds the processing was done.

I’m running it on Windows, but this should not make a difference.
Do you have installed the latest updates?


Hi marpet thank you for your quick reply, I really appreciate it, see that you even used the same dataset, the version I’m currently using was downloaded last week so I guess its of the latest, I’ve been trying, restarting the computer, SNAP, and it still doesn’t work, even with only that single subset node.
Are there any logs of the graph builder I can access and see what is happening?

After installing the downloaded SNAP version, you need to download and install the latest updates too.
Just select from the menu ‘Help / Check for Updates’ and then perform the suggested update.

How to access the log is mentioned in the SNAP FAQs

1 Like

Dear marpet,
I cannot believe that fixed the issue… sorry to have wasted your time, best regards!

1 Like

No problem. I’m happy to hear that it now works.

1 Like

it does! thanks again!