Graph Builder Subset and Terrain Correction Error Sentinel 1

If I import the WKT (Now converted to a Shapefile) into each product and plot them I get:

Raw Sentinel 1 GRD Product:

GPT Subset Product:

SNAP Subset Product:

It appears that GPTs data is correct, but it is not in the correct position, whereas SNAPs subset data is dead on.

1 Like

Thank you for testing.

@lveci is this a bug?

Interested to see what folks say! :sunny:

Hi Ciaran,

i came across similar problems in the past.
For me it has always worked when putting the subset operator at the end of the graph just before the write-node. This also seems to affect the previous steps, i.e. the subset seems to be applied from the beginning on, as processing time is much shorter than when processing the whole scene.
Have you tried that already?


that is a very interesting point!
I would love to see some benchmarking tests on execution times.

@gepo1 I have not! I’d always assumed it would be applied after the other steps therefore making the addition of it pretty useless in my case (where I wont need the whole image).

I will definitely check this though!

I’ll let you know how it goes! :slight_smile:

1 Like

@gepo1 @ABraun unfortunately that doesn’t appear to be correct :frowning:

You can see that the processing was a lot quicker, 63 seconds (with the subset) vs ~20 minutes to process a whole scene.

Unfortunately when I import the WKT into the Subset dataset, it is still not located on the data.

I experience the same results with Copy Metadata true and false

to my understanding, the difference which @gepo1 pointed out was the position of the subset within the graph, not if it is used at all.

I would have placed it at the beginning based on my logic that it reduces processing time but obviously at the end is an option too.
As I understood him, even if the subset operator is placed at the end, it will reduce the processing time (even more than at the beginning?)

Ah right. Well, it definitely speeds it up.

Still seems that Subset isn’t working as I’d expect it to

yes, your problem is still open. The developers are probably busy at the moment finalizing the SNAP 8 release, but I’ll keep an eye on it.

Okay thanks! Is there somewhere I can raise it as an actual issue? Or check whether it’s been raised before?

yes, here:
But I am not sure if every one can submit an issue.

You can have a look if yours is already addressed. If not, please send me a short but clear summary which I can then enter as a new issue.

Yes, looks like I’m unable to create one.

Subset Operator in GPT does not correctly geo-reference products whereas the SNAP Subset Operator via the GUI does.

When importing the GeoRegion as a Shapefile (produced from the WKT), the GeoRegion overlaps the products subset using the SNAP Subset Operator, it does not overlap those subset with GPT.

Final product should be the result of Subsetting, Radiometric Calibration (Intensity_VH), and Terrain Correction


Subset GeoRegion:
Polygon ((-97.56358828861178267 14.96860616344341643, -97.56358828861178267 14.73100794671138303, -97.10260713307185654 14.73100794671138303, -97.10260713307185654 14.96860616344341643, -97.56358828861178267 14.96860616344341643))

1 Like

@ABraun hopefully that’s useful, if you can include images I think Graph Builder Subset and Terrain Correction Error Sentinel 1 and Graph Builder Subset and Terrain Correction Error Sentinel 1 would illustrate the problem better than my words!

thank you @CiaranEvans, I added it as an issue:

Brilliant, thanks! Really appreciate all your help!

This topic (possibly different reasons) still seems to be open in SNAP 8.0.8. Is GPT used also when using the graph builder in SNAP?
Use of the subset module (I put it in the beginning of my graph though) subsets a different area compared to what the coordinates (as given by other software, e.g., QGIS) actually cover, and the geocoding (terrain correction) is incorrect - seriously off (several kilometers in my case, possibly related to the subsetting properties).