Graph Building Error


I am trying to build a graph for a S2 Level 1 imagery. One of the steps is to resample the bands, when I am selecting the parameters I get an error: Error:[Nodeld:S2Resampling}. Invalid S2 Source Product.

The product is the valid one because I try to do it all step by step without the batch processing and it runs fine.

Any suggestions?

Hello @elviajedejen ,

What SNAP version are you using?
Can you save the graph as xml file and upload it here?


Hi Diana,

It is the latest version, 9.0.0.

I am new to the graph building. I had tried it years before, but always gave up. But this year I really need to build it to further my work.

Here is the graph xml:

resampled graph builder.xml (1.8 KB)

Also, I tried to do the graph builder but for apply 22 shape files of different land mask to a satellite imagery. It ran, however in some of the mask that it applied y seemed really off. I did the same but mannualy and it ran fine. any suggetions? I am also attaching the graph builder that I did

mask Graph with everything selected.xml (11.3 KB)

Thank you in advance


I am uploading the steps that I want to do on the graph builder for the first, that includes the resampling one

Hi Jenifer,

  • If you run the graph from command line, using gpt, do you have the same error?
    (gpt “<path to graph XML file>”).

  • In SNAP, is the error still present if you select the Source Product (of the Read operator) from the disk using the ‘…’ button?

Hi Diana,

Thank you so much for your quick response.

I haven’t tried it by gpt path. I am only trying it in SNAP…

Can you try both tests from my previous comment and let me know if you have the same error?