GRD co-registration error


I have spent many hours trying to do co-registration of GRD products with no success.

I have a stack of 33 images (all Ascending) that I want to pre-process and then co-register as I require a high level of spatial accuracy for change detection.

My pre-processing chain is as follows:

Read -> Subset (wkt polygon) -> Apply Orbit File -> Calibration -> Multi-look -> Terrain Flattening -> Terrain
Correction (Range-Doppler) -> Linear to dB

GRD_UnityWater_preprocessing_blank3.xml (6.2 KB)

This chain works very well, and I get consistent results without any errors.

However, when i go to use either the DEM-coregistration or the ‘Coregistration’ (Create Stack) functions, I get one of two errors:
DEM-coregistration returns “ stack contains no elements”;
and the Coregistration function returns something about no array (sorry, I didn’t copy / save this message)

I have tried to remove the subset function in case this is the cause, and instead I get the slave images as being outputted with only 0 values, and the same error message as before.

Can anyone please help and suggest why this is going wrong?

I have the latest version of the software and it is fully up to date.

Many thanks!

Full error message below: stack contains no elements
at jogamp.opengl.GLStateTracker.popAttrib(
at jogamp.opengl.gl4.GL4bcImpl.glPopClientAttrib(
at gov.nasa.worldwind.terrain.RectangularTessellator.endRendering(Unknown Source)
at gov.nasa.worldwind.terrain.SectorGeometryList.endRendering(Unknown Source)
at gov.nasa.worldwind.render.SurfaceTileRenderer.renderTiles(Unknown Source)
at gov.nasa.worldwind.layers.TiledImageLayer.draw(Unknown Source)
at gov.nasa.worldwind.layers.TiledImageLayer.doRender(Unknown Source)
at gov.nasa.worldwind.layers.AbstractLayer.render(Unknown Source)
[catch] at gov.nasa.worldwind.layers.TiledImageLayer.render(Unknown Source)
at gov.nasa.worldwind.AbstractSceneController.draw(Unknown Source)
at gov.nasa.worldwind.StereoOptionSceneController.draw(Unknown Source)
at gov.nasa.worldwind.BasicSceneController.doRepaint(Unknown Source)
at gov.nasa.worldwind.AbstractSceneController.repaint(Unknown Source)
at gov.nasa.worldwind.WorldWindowGLAutoDrawable.doDisplay(Unknown Source)
at gov.nasa.worldwind.WorldWindowGLAutoDrawable.display(Unknown Source)
at jogamp.opengl.GLDrawableHelper.displayImpl(
at jogamp.opengl.GLDrawableHelper.display(
at jogamp.opengl.GLDrawableHelper.invokeGLImpl(
at jogamp.opengl.GLDrawableHelper.invokeGL(
at sun.awt.RepaintArea.updateComponent(Unknown Source)
at sun.awt.RepaintArea.paint(Unknown Source)
at Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$ Source)
at java.awt.EventQueue$ Source)
at Method)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$ Source)
at java.awt.EventQueue$ Source)
at Method)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at org.netbeans.core.TimableEventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at Source)

UPDATE: I have tried removing the Linear to dB option as I saw worked for one person, and got more odd results / errors:

When using the DEM co-registration for three images in the stack, I got an output, with complete bands, but the images themselves now have missing strips / holes of data:

The original Master image is in the lower window of the above image.

When I ran the Co-registration function (Create Stack) I got the below error:

The output did not open in SNAP (because it did not complete writing) and the saved partial file contains one master and one slave image half complete / written, so it looks like the process fell over half way through co-registering the first slave to the master image.

Please can someone help to explain these odd results?!

The error shown in the initial post (stack contains no elements) is not linked to DEM-assisted Co-registration, in fact it occurs when the GRD zipped (uncompressed) files are loaded into the GUI (via drag and drop). Is this a known error? And does it actually impact the following processing?