Help with collating S1 GRDH and S3 SL-1-RBT

I have made a graph(.xml) in which I want to collocate Sentinel-1 and Sentinel-3 RBT images. It does not work, and I wondered if anyone could help out:

I couldn’t make the graph using the graph-builder for some reason, so I made it by writing in notepad and copy-paste, the graph is attached here.

I want to load both a Sentinel-1, and a Sentinel-3 image, I then want to process the S1 image slightly, and then collocate them, with S1 as Master, and write it out as a GeoTiff. My inputs in the graph are the sentinel-1 GRDH image, the sentinel-3 SL-1-RBT image and my targetfile.
s1_s3_collocate_step_forum5.xml (5.2 KB)
I am calling it in the cmd as so:

gpt “C:\graph_folder\s1_s3_collocate_step_forum5.xml” -PtargetFile=C:\target_folder\name_collated -SsourceProduct_s1=“C:\s1_folder\” -SsourceProduct_s3=“C:\s3_folder\S3A_SL_1_RBT_name.SEN3"”

I have two problems:

  1. it keeps on giving me errors, e.g. “Error: [NodeId: Subset] Operator ‘SubsetOp’: Mandatory source product (field ‘sourceProduct’) not set.”

  2. In actuality, I would like to take a subset of the S3 bands. Can this be done by this snippet for each band, or would I have to write it afterwards? If yes, how to I send all the subsets to be collated? Would it be better to take a subset of the bands after I have collated?


    Reproject S2_radiance_an

I am working on Windows 10, 16 Gb ram,

best regards,

This is an image of your graph

Even when you give the input products with the GPT you need the Read node at the beginning of each thread (before Subset and before Reproject)

Hi Andreas,

Thanks for the quick reply! I have put in two read nodes.
I still get the same error though.
When I try to edit my graph using the grapbuilder (with my files loaded) it takes like 5 min to change one single thing. Is that normal? (it’s not the case when I’m only working with s1 files).
This is my updated graph
s1_s3_collocate_step_forum6.xml (5.6 KB)

I ran the the command with the -e option, and the extensive error message is attached

Obviosly, I can see that the error is in the ReadNode2, and that it’s not reading the file. I’m just too green to see why.

This is my exact command:
gpt “C:\Users\krist.snap\graphs\s1_s3_collocate_step_forum6.xml” -e -PtargetFile=C:\Users\krist\Documents\Syntese\data\collocate_testfolder\xfdumanifest.xml_collated -SsourceProduct_s1=“C:\Users\krist\Documents\Syntese\data\collocate_testfolder\” -SsourceProduct_s3=“C:\Users\krist\Documents\Syntese\data\collocate_testfolder\S3A_SL_1_RBT____20180721T200909_20180721T201209_20180723T011520_0180_033_342_0900_LN2_O_NT_003.SEN3”


this usually happens when the Apply Orbit File operator is added, but in this case I have no explanation.

I am not an expert with graphs, but I guess the GPT cannot relate
ReadNode to -SsourceProduct_s1
ReadNode2 to -SsourceProduct_s3