How to create mosaic of JERS-1 data

Dear all

I got a problem using Mosaic as well
I would like to mosaic JERS1 level 2.1 datasets from jaxa.
I have tried every possible way i could think of using SNAP (GUI and gpt), but nothing works so far
so currently, after pre-processing JERS using SNAP gpt, i use other software for mosaicking
but it become ineffective since I got many datasets to work with
so I want automation with SNAP GPT, but had no luck so far

So, first I try SAR-mosaic under Radar tools,
the inputs are JERS1 TIF LEVEL 2.1
and I got this error
[NodeId:SAR-Mosaic] Metadata range_spacing has not been set

I used this tool before for Palsar 1.5 from ASF server, and it worked perfectly well
unfortunately, they only provide JERS1 in level 2.1 and 0

so, next I try mosaicing under raster tool (geometric operation),
i use inputs after reprojection to UTM
but i didn’t work either
the error is:
Cannot display source products. java.lang.StackOverflowError

so, next I try use SNAP gpt command line
gpt Mosaic D:\folder\JERS1_1992-10-26_118-300.tif D:\folder\JERS1_1992-10-26_118-299.tif -t D:\folder\Mosaic.tif

and I got error again:

Next I tried using graph builder,
but I could not find it in my graph toolbox (i use version 5.0)
so, I used your xml code above,
I got it executed, but when I open the output in ArcGIS
i got image with 2 bands with 0 DN for all pixels

so, I don’t know what else to do, or where I got it wrong

Thank you for your attention


I don’t know the JERS data, but I guess the tif files do not provide enough meta information to be used with the SAR-mosaic.

This does not work because the area you of your data is not located in the default area of the mosaic.
Try the Mosaic in Raster/Geometric Operations from the menu.

The XML you mention is not shown.

At the end, it can turn out that this JERS data you have is not supported in a way you need it. As far as I know, JERS is only supported in CEOS format.

Update: I moved this to a separate thread

1 Like

Thank you Marpet

I did try with ‘Raster Mosaic’, but got another error

i execute it and the output is nonsense

the xml I mention is from to123’s post here


I am trying to do Polarimetric Analysis for ALOS Palsar Full Polarimetric data.
I have several swaths and would like to combine them before applying Polarimetric Classification.
If I classify them first and then Terrain Correct and Mosaic the classification results the classes of the mosaiced scenes are not matching each other.

Is there a way to mosaic ALOS Palsar data before Polarimetric Classification and Terrain Correction?



1 Like