How to export chl-a concentration from snap to ArcGIS

hello. may i ask how to export the loaded chlorophyll-a concentration from snap-s3 toolbox which can be loaded in ArcGIS? i had loaded a data (satellite image) full resolution, acquired from eumetsat-earth observation portal. after loading it in snap, i exported it into geotiff-bigtiff file. however, when i loaded the exported data in arcgis (arcmap 10.4.1) the pixel values changed. i don’t know what’s the problem though.
attached below are the data acquired and the data i want to export, respectively.

There are several things to consider. To only have the CHL_NN in the output file for ArcGIS you need to tailor the dataset.
You should do

  1. Reproject the data to a CRS you want, e.g., WGS84 or UTM (Raster / Geometric / Reprojection)
    Deselect already the reprojection of tie-point grids.

    It is not necessary to save the result to disk.

  2. Get rid of all other bands by creating a subset. (Raster / Geometric)
    Select only the single band
    When you are asked if you want to include flags, select No.

If there is still another band, select it and press DEL to remove it.

If you now export the data to GeoTiff you should get the result you want.

The reprojection is necessary because the data uses pixel-based geo-coding and the geo-location information is stored in bands. Without reprojection you would have at least the lat/lon bands to keep the geolocation. The subsetting removes the other bands. Having all bands in the geotiff it is difficult to find the band you want in ArcGIS. In addition, the reprojection step applies the scaling and offset factors which are used to convert raw values to geo-physical values. In GeoTiff the raw values are stored if they are not converted before.

1 Like

however, after it was loaded in the ArcMap, the lowest values are negative. is it right for the chlorophyll concentration? doesn’t it must be 0.01 mg.m-3?

I was able to reproduce this. And this seems to be related to the fact that the data is marked as logarithmic.
I’ve used QGIS to reproduce this case.

In the lower left you see the layers:

  1. The GeoTiff created following my suggestion above
  2. The imported directly from the S3 product directory
  3. The new GeoTiff created with an additional conversion step

It seems one and two do not consider that the data logarithmic.
For three I’ve used Band Math to apply all conversion which are usually done on the fly directly to the new band.
Simply right click on the CHL_NN band, after the steps from above, and select Band Maths.
Give the new band a name a deselect the Virtual option.
Afterwards you can delete the original band and now export the data to GeoTiff.

I’ve noted this as an issue:
[SNAP-3510] When exporting to GeoTiff logarithmic attribute of data is note correctly considered - JIRA (