How to open Landsat 8 surface reflectance in SNAP

Hi, this is pretty nice to see. Honestly we haven’t looked in detail how to support the SR data till now. It is goo to know that there are some issues with the format.
Have you reported this to USGS?


Yes I did :wink: now waiting for the answer.

The normal Landsat data contain different scaling factors to get radiance or reflectance values. But both TOA. Here we talk about surface reflectance.

Hi, I think I did everything that is mentioned but I still cant run it.
Here is the folder and the mtl.

LC81830312017179LGN00_MTL.txt (8.3 KB)

I just checked it and SNAP v6 fully supports Landsat 8 L1T products.

Just open the MTL file with the “open” dialogue in SNAP or simply drag-and-drop it into SNAP.

Thanks!, I just came in to say that I managed to do it. What worked for me is that the end of the name of each band wasnt _BAND1 but _B1. Then I removed the Filename_Band_quality line in the mtl file since I dont have such file in the folder and it worked. I tried dragging another mtl file but I get the error in Snap.

good to hear that it worked, although it is kind of strange. Were you using the latest version of SNAP?

yes, no updates available. I also see you get flag codings and masks, something I dont have when opening it.

You don’t have the quality band in your data. That’s why you don’t see the flags

Yes I dont have t he BQA in my data from earth explorer. I still had this line in my MTL, I had to remove it so I can open the image in SNAP. Any ideas why it is missing from my order?

Maybe the order was not processed correctly. Also some other bands are missing in your data. Maybe retry to download the data. And to verify try also another location and/or time

Thank you, what I tried is that I downloaded the level 1 product for the same date and it directly opened by SNAP, having the BQA file. No issues with naming. I am also albe to run idepix. I will try to copy the BQA to the SR product and correct the MTL and see if such moves are possible :smiley:

Yes well that works but I cant do the cloud mask with idepix, propably because not all bands are present. So I will reorder the product. Hopefully it will be different, otherwise I have to use level1 and to the atmocorrection on my own

Good morning,

I have done the corrections of .MTL file for Landsat 8 L1TP format to work on reflectance TOA data with SNAP…but I still have values in radiance (w/m²/str…) between 0 and 1.6…

I put
RADIANCE_MULT_BAND_1 = 0.0001 etc. and

Thanks for your help,

But a value range of 0 to 1.6 is an indicator for reflectances.
You can also set a property in order to switch between radiance and reflectance, see:

Hi marpet,

I’m trying to process Landsat 8 L1TP data using SNAP by C2RCC processor. I couldn’t able to run it. The following error is popping out as follows

looks like you only loaded band 1 as a tif file into SNAP.

Please use File > Import > Optical Sensors > Landsat to load the enire stack. Problems with opening Landsat data

Hi ABraun

I tried to do as you said but the following error occurs. Please help me to resolve this issue.

where did you download the data and which product level exactly?

I got it now.
Actually, I downloaded Landsat collection 2 data which is not working initially.
Now I downloaded Level-1 GeoTIFF Data Product.

Thanks for your prompt responses. If I’ve any questions in near future will let you know.
Again Thanks

yes, the collection 2 products are not supported yet.