How to overlay multiple point vectors on rasters?

Hello all,

I’m currently facing an issue when adding a shapefile (multiple points geometry).
SNAP seems to read the file as it finds well the dataset’s bounding box.
However, I cannot see the geometry when it is added to the Layer Manager (see the image).
Also, it works fine when opened on QGIS.

Do you have any idea of the reason for this ?

Thank you and have a nice evening.


is your SAR data projected?
Do both of them have the same coordinate reference system?

What happens when you open the vector alone in the layer manager?

1 Like

Dear ABraun,

thank you for your answer.
Actually, these are Cosmo-SkyMed product in SLC (L1A) processing level. Amplitude has been extracted, and a coregistration between two products in interferometric conditions has been realised. Finally, products have been flipped (with the data flip tool) but they cannot be terrain corrected properly as there are no tie-point grids (from what I understood). All vectors are in same coordinate reference system.

What I forgot to mention is that I can add other vector (polygon shaped) from the same dataset and it works fine (see the attached image).

What do you mean by “open the vector alone in the layer manager”? It seems I cannot open a vector if there is not a raster opened.

Sorry, you’re right. It is surely strange that it works with polygons but not with points.
Would you mind sending me the points?

Dear ABraun,

sorry for the late answer, I didn’t see any notification of your answer.
You will find attached a zipped extract of the points shapefile.

Thanks for your help.

test.7z (1.2 KB)

i just tried them on 90m SRTM data and it seems fine.

Maybe you there’s a problem because your SAR data is not projected yet.

1 Like

Okay, I tried using a well geocoded and geoprojected SPOT image having the same bounding box than the SAR data but it still doesn’t work.
Maybe I am not adding correctly the vector importing tool (I’m using the LayerManager panel on the right side of the software) or maybe I am having some configuration error on points geometry : indeed, it is like the software recognizes the dataset when imported (bounding box is correct on the second step of the layer import process) but I cannot “see” the points when imported. I tried to configure the layer style of imported vectors but it seems it didn’t work.

Do you have any idea ?

Thx a lot !


have you tried selecting the raster data, then import > vector > Shapefile?
This worked for me

1 Like

Great! It worked for me too using that command. :smiley:
Thx a lot !
Do you know how to edit the layer style afterwards ? I’m using the layer editor to modify it but it’s not working.

I also had struggles to change the colors and marks of the points. Seems a bit tricky :slight_smile:
I’m happy it worked.

Okay, no problem. The most important thing is that I could add these data over the raster file.
Thanks a lot again, have a nice day.

@ABraun Is there a way to highlight a particular attribute from the shapefile and view the corresponding in the image display area? Also any progress on modifying marks and colours of points? Thanks in advance!

Sorry, I don’t understand what you mean. Can you give an example?

1). Zoom map to the selected row from attributes table. An example from QGIS is as below. I’ve selected a point from the attribute table and there’s an option to zoom in to that on the shapefile (shown in yellow)

2)Sometimes it’s hard to see the “white cross marks” from the point shapefiles due to the image colors in the background. Are there options to enhance/modify symbology, change colour etc


I see, thank you for the explanation. The styling of vectors can be edited in the Layer Manager.

Regarding the zooming - if you work with pins, you have more flexibility regarding their handling in the Pin Manager. But I don’t know if points imported from a shapefile can easily be converted to pins.

1 Like