I can't open items in bulk, only one item is loaded after loading

I can’t open items in bulk, only one item is loaded after loading.I also can’t update QQ截图20201009221315 ,I don’t know how to do
please help me ,thank you in advance

maybe the products were not fully downloaded?
Can you please check their file sizes?

I downloaded it with a python script

could you tell me how to know they are fully downloaded please?

check the file sizes. Each zip file should more or less have the same size as the one which worked.
Especially with python scripts, some zip files might seem complete, but are only parts of the total.

You can also try to unzip the files before loading them. If the extraction fails the product was not downloaded completely.

I selected all the files and dragged them into the SNAP window to open 17, but only 7 can be opened with the menu key.

I understand, but I cannot tell you the reason without more information from you. You have to check the file sizes of the downloaded products.


looks ok for single-polarization data.

What happens if you drag them in ony by one? Will they be opened or is it always just the same 7 that work?

some can be opened ,some can not :sob:

please delete the ones which cannot be opened and run the python script again. It is very likely that parts of the data are just missing.

Ok, thank you very much, can I ask again why the plugin update failed

let’s ask @marpet with the update issue - do you see a reason why the check for updates worked but not the connection to the center?


1 Like

No idea why this didn’t work. In both cases the same server is accessed.
Maybe something went wrong in between. Maybe the server had some issue.

The first message is shown when the meta-information downloaded and scanned.
(e.g. http://step.esa.int/updatecenter/7.0/snap/updates.xml.gz)
But when does the second happen. When actually trying to download the updates?
@501756347 When does the second message show up?

When I clicked on update, after a while it appeared

When I run the update file (.xml) with the terminal, the following error appears

please help me ,thank you

The xml file cannot be used with gpt on the command line.

You can try if you can download the files manually from this location:
Index of /updatecenter/7.0/snap-extensions (esa.int)
If not it might be some firewall restriction.

You can also try to follow the update process on the command line described here:
Update SNAP from the command line - SNAP Wiki

In a nut shell, it is this command:
snap --nosplash --nogui --modules --update-all

Thank you very much for your reply