iCor for S3 missing basic flags and geolocation

Dear all,
I am using the iCOR v1 OLCI under SNAP v6 to carry out the atmospheric correction. I used OLCI-A L1B data as in put. I open them in snap and after I use the iCOR OLCI processor. When I got the out-put. I did not found any flags. After I want the extract pixels with no success. In the out-put there is no geolocation. I tried to change the out-put format to NetCDF4. The issues are not solved. Can I have help ?

Hi everybody,
Also in my case after iCOR the OLCI image has no coordinates. I tried to run iCOR with the apply projection option checked and with the keep intermediate files option but in all cases the geolocation was missing from the product.
In the latter option you get 3 masks (cloud, water, AOT) as individual products, is that what you are looking for?

Hi everybody,
Thanks for your feed-back. Yes I saw that masks can be obtained with keeping intermediate products, but I am looking to have them in the same file with bands. The aim is to extract pixels following the flags. For the geolocation I tried as you did with no success.

A possible solution for missing coordinates:
Run icor for a S3 image and find the results in a folder named:
C:\Users\XXXXX\AppData\Local\Temp\icor_dnmd58_proc (or something similar).
In this folder there are several reflectance tifs, among them there is one with its name ending in xxx_dark_corrected_surface_reflectance.tif and two others with their name ending in xxx_latitude.tif and xxx._longitude.tif. The first one has the reflectances for the 16 bands according to icor manual.
Open (add layer) all of them in QGIS and use the merge tool (check "place each input file into a separate band). Save as tif.
Open the new tif in snap and use the “Attach Pixel Geo-coding” found in Tools menu.
That’s all: you should have coordinates in your image!!!

1 Like

Hai Thanks for your suggestion, I tried

after ICOR run …Load surface reflectance.tiff , lat, long file in tiff in QGIS and I added layer

but after the merge process i could see 23 band in output image , also bant not opened,

How to resolve this