IdePix Classification

Hi all,
has anyone experience with the IdePix Classification of Landsat 8 data? It can be found in Optical > PreProcessing > IdePix Pixel Classification > Landsat 8.

I am currently struggling with the required input format. Here is what i tested so far:

  • Import of L8 data via the MTL file: bands and satellite are recognized in the metadata, but the operator requires reflectance values
  • Import of a LayerStack with reflectance values: I added the wavelengths and band names in the metadata and changed the product type to “LANDSAT_8_OLI_TIRS_L1T”. Then I get an error that only certain satellites (including L8) are supported. It seems that SNAP no longer sees the input as a Landsat 8 scene.

Any ideas how to overcome this?

Thanks in advance!

unfortunately landsat8 is not yet conveniently usable with IDEPIX.

In the help is a section which explains how to make it work.
In the processor menu invoke help and choose ‘IDEPIX Processor Description/Landsat-8
Please have a look at the beginning of ‘The Processing Parameters’.
There it is explained how to set a property.
Afterwards landsat is read in reflectances and can be used with IDEPIX.

1 Like

thanks Marco!
I read the documentation but somehow overlooked the part with the ""-file. In fact, this was the solution:

The pixel classification for Landsat-8, i.e. all the cloud tests, work on TOA reflectances rather than radiances. As the Landsat-8 product reader by default interprets the spectral band values as radiances, a specific property must be set to read the data as reflectances before using Idepix:

if not present, create a file ‘’ in the folder [USER_HOME]/.snap/etc
in this file ‘’ add the entry


I am trying to run IdePix on a sentinel 2 product containing only one band (so I don’t have to resample) and I get the exact same message…

I am at loss with what to do from here…


I’m not an expert but I guess IdePix is based on multispectral information and doesn’t work on one single band.

Edit: As stated in the message, it currently only works for Landsat 8 and the other mentioned products. So Sentinel-2 data is not yet supported. This turned out not to be true, as clarified by mpeters below. Sentinel-2 data is supported

Ahah ok makes sense if Sentinel-2 data is not supported… Thanks for the info!

I’m trying to create custom cloud mask and export as GeTiff but failing… It just creates black images.
Details of the problem and what I tried are here: Cloud mask - SNAP sentinel 2

Any suggestion?


Actually, Sentinel-2 is supported. It is only missing in the error message.
But as Andreas already said, it needs spectral and other information which is contained in a standard S2 L1C product. It is not working with a single band.

HI again,

I am wondering how long the idePix algorithm is supposed to be running when working on a Sentinel level 2 file (~800MB)?
I have clicked “run” about 1h ago, and nothing is happening so far, SNAP just froze and I have to force quit it.


The duration of the processing is dependent on several things. DEM data need to be downloaded for the area when processed for the first time. Then it has a big impact to which resolution you have resampled the L1C data and if you have stored the resampled data or directly go on with IdePix, and finally it depends on your PC. Which Processor and how much memory is available?

I just did it. The DEM data was already locally available and I have resampled to 60 meters, without storing resampled data to disk. It took less than 13:30 minutes. Then I did it on 10 meters resolution and it took only 10 minutes. Probably because the source L1C data was already cached and all DEM data loaded.
My PC: Intel Core i7-5820K 3.3GHz - RAM 16GB


Thanks for testing all this!
I’m new to remote sensing, DEM stands for Digital Elevation Model right? Does SNAP has to download them for every image we process?
My internet connection is very slow, maybe that’s why… But then my study area is covering only 2 tiles, so I’d assume once it has been dowloaded for 1 image, it should be able to process the images from the same tile faster right?
I had resample to 60m resolution and only open the resampled product on SNAP.
I’m on a MacBook Pro 3 GHz Intel Core i7 RAM 16GB


Your computer is powerful enough and not the bottleneck, but your internet connection is. You are right DEM stand for digital elevation model. The download DEM tiles are cashed. Once you have them for your area it should go faster.

Ok thanks!
I will try to get a faster connection at some stage to try this then.


Hi guys, can you share the"-file. here. Thank you, Im not sure I can create such animal.

Here you go. (32 Bytes)

Thanks, after posting I realized I can copy the other properties file and use notepad. But anyway it will be convenient for others.

Unfortunately, the problem persists. Here is my MTL file, I have the feeling the problem might be inside somewhere. I will keep looking for the solution.

LC81830312017179LGN00_MTL.txt (8.3 KB)

What’s the problem? You don’t get the reflectances?

Hi marpet, I mentioned the problem in the other topic. The problem comes from the lack of BQA band but also from the fact that my order is missing all the bands, therefore the product is not readed as L8. Hopefully, I the problem will be solved with a new order from earth explorer.

Thank you for your quick answers and feedback!

So I reordered the SR product and it is the same case, I miss some of the bands and the BQA band. Now I think I have two choices, to use the Level 1 product, perform atmospheric correction myself and the do the cloud mask. Or another strange move, the bands I am missing wont be used in my analysis, I only need RGB and NIR. So What If i combine level 1 missing bands with my SR product just to be able to run idepix, do you think that will work fine? I will try it later.


Idepix needs all 11 spectral bands. It is not using the flag band.

Hi, yes that is true. I’ve contacted the earth explorer support and they mentioned that not all L8 bands are used for SR product, unfortunately.