Idepix.Olci Operator with CloudBuffer

Hi,

When using Idepix.Ocli operator with cloud buffer I observe following problems:

  • when launched from SNAP GUI it just hangs at some point (Optical -> Preprocessing -> Masking -> IdePix (…) -> IdePix Sentinel-3 OLCI)
  • when launched using GPT I get org.esa.snap.core.gpf.OperatorException caused by java.lang.NullPointerException (sadly the stack trace is truncated and I cant see the code line where it really comes from)

When I turn “computeCloudBuffer” off, it works. (GUI and GPT)

I’m using SNAP 7 with all plugins installed on Windows 10. Clean installed, nothing upgraded.
I tried several Sentinel 3 OLCI products.

More details by tomorrow.

Edit 2020-03-18:
Details:
SNAP-Desktop: 7.0.3 (newest by 2020-03-18)
SNAP-Engine: 7.0.3 (newest by 2020-03-18)
JRE: 1.8.0_202
IdePix OLCI Plugin: 7.0.2 (newest by 2020-03-18)

The issue was discussed in this topic. Maybe will give you some insides of the problem. Also you should update Idepix.OLCI as @marpet said in the post below. Cheers!

Hey, thanks for your answer! Yep, I found that topic as well. But I think they tracked it down to the reprojection.

If it turns out its really the same problem, feel free to close this topic because of duplication.

Hi, could you please provide the exact version number of SNAP and IdePix?

SNAP version you can find under Help -> About
IdePix version for OLCI and core you can find under Tools -> Plugins. Then go to the installed Tab and search for “IdePix OLCI” and “IdePix Core” Version should be something like 7.0.2

Cheers,
Jan

I found in our application (yep, I am new to that), that a reprojection is used indeed, but prior to Idepix.Olci. So I tried it with and without reprojection before Idepix.Olci. See attached files for reproduction.

console.txt (9.1 KB)
idepix.olci_fail.xml (318 Bytes)
idepix.olci_success.xml (319 Bytes)
reproject_idepix.olci_fail.xml (977 Bytes)
reproject_idepix.olci_success.xml (978 Bytes)

Thanks for the detailed report.
Indeed I was able to reproduce it with the latest OLCI Idepix (v7.0.2).

The error in the reprojection graph happens when both parameters computeCloudBuffer and computeCloudShadow are set to true. If one of the two is set to false the processing works.

Probably the problem is that the viewing geometry is not anymore what is expected after reprojection. Idepix is expected to run on the original data.
It helps to do first a subset, then the idepix and in the end the reprojection.
I’ve created an example graph: exampleGraph.xml (2.3 KB)

The failure in the graph without the reprojection is probably caused by memory issues. We need to work on this. But adding a spatial subset before the idepix node might help here too.

Thanks again, for the report.

1 Like

And here is the changelog for OLCI I’ve mentioned.