Illegal filename format with srtmgl1 HGT dem

I am running a graph on linux with up to date 6.0 with gpt to do backgeocoding and esd on 30 SLC layers. The error message: SEVERE: org.esa.snap.core.dataop.dem.ElevationFile: Illegal file name format:
INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving
I ran all these files yesterday and it supposedly downloaded all the DEM files then, but I just started this graph a few moments ago and it seems that it doesn’t know where it put the files from yesterday or what they were called? Why should it have to download them again? Where does Snap store the DEMs on Linux? I would like to download them all at once and put them in the right spot ahead of the run to save time.

1 Like

SRTMGL1 files should be located in your home directory (~) here:
~/.snap/auxdata/dem/SRTM\ 1Sec\ HGT/

I am seeing the same error when using auto download SRTM 1Sec HGT for both Terrain-Flattening and Terrain-Correction in my GPT graph. No error if using a different DEM for one or the other.

I have the same problem whitout any answer.
Did somebody know how the avoid re-downloading ?

In case you are also using SNAP 6.0 as described in the first post, please update to SNAP 7.0.
Otherwise please specify your problem a bit more (operating system, data, processing step…)

I found the origin of the problem on Linux SNAP 6 version.

It seems to come from the multithreading, when different threads access to the SRTM tiles. In that case, threads generate the error “Illegal filename format” and try to re-download the data.
If you desactivate the multithreading (by using “-q 1” option in gpt command for example), there is no more error and SNAP uses all the SRTM data already on disk, without re-downloading them.
I don’t know the error occurs also in SNAP 7. I will test later.

1 Like