Image Coregisteration

I want to make a dInSAR interferogram out of two sentinel SLC images each about 4 GB of size, but the problem is that my machine is a bit slow. 4 cores processor and 4 GB RAM and no special GPU. When I go to Radar>Coregistration >S1 TOPS Coregister and select the images and selecting my required subswath IW2 and first just three bursts. For VV polarization only.
At first it showed error that no orbit file is present so I manually downloaded the orbit files for each image for S1A and B total 4 orbit files.
When I run the process nothing starts and progress bar is at 0. Even the system is running fine as it should no professor cooling fan starts buzzing and it’s like I never even clicked on start.

Please tell any alternative way of selecting the IW2 for both images and later coregistering them. I even tried to seperate the subswath by selecting one image and going to S1TOPS in dropdown but when I open coregisteration wizard it says images must have subswaths type error.

The TOPS Coregistration graph is not meant for machines with little capacities.

4 GB might not be sufficient, but you can try to perform the tasks stepwise

  1. TOPS Split (select subswath and reduce as many bursts as possible)
  2. Apply Orbit File
  3. BackGeocoding
  4. Enhanced Spectral Diversity (in case you have more than one burst)
  5. Interferogram formation
  6. TOPS Deburst
1 Like

Thank you. What kind of processor and RAM I need to instantly perform these kind of works in future?

depends on the data volume. On my 8 GB Notebook working with 1-3 bursts works, but anything above this requires more.

1 Like

Does the SNAP require more RAM or processor cores? Lets say in future I plan to use Quad Pol Radar SAT data.

RAM and a high reading/writing speed of your hard drive is more important than many cores. If you have the chance to process data on a SSD, things will recognizably speed up.

I have SSD thank God haha

The spilt and orbit file process was instantaneous. Now the back-geocoding is taking hours and I am still stuck on this screen. Computer is under no load at all in task manager.
Screen Shot 2021-02-11 at 6.30.55 PM

Screen Shot 2021-02-11 at 6.30.46 PM

Please update to the largest version of SNAP.
The problem is described here: Problem in the last part of snap to stamps

1 Like

Updated still nothing :frowning:

What happens when you select SRTM 1Sec instead?

1 Like

Thank you it worked. The update worked. At first I kept old user data but then uninstalled again. Cleared the caches and registries. Installed the new SNAP 8.0 Updated all the plugins. I forgot to thank you. :slightly_smiling_face: That bird is really beautiful. You can close this thread.

1 Like

very good, thank you for reporting.

1 Like