Image is stretched and gaped after pre-processing

Hmmm. I feel like I’m doing something wrong that’s so basic that everyone else wouldn’t have thought to tell me I should or shouldn’t do it. Also, I’m looking at the open areas in the ocean, the polynyas, so I do need the full stretch off the ice shelf sometimes.
I notice that you’re using sigma, I was told to use gamma: does that have anything to do with this?

I don’t think that the introduced pattern is caused by the difference of Sigma0 and Gamma0.

Your product is upside down compared to mine. Are you sure you have not accidently selected Stereographic North Pole?


Have you checked if the pixels are still inside the product before Ellipsoid correction?

How does one do that?
Also, I noticed at your image comes form Sentinel 1A and I have been using 1B. How much of a difference would that make? Attempting to download the same image but will have to wait for offline retrieval.

Sentinel-1 A and B are quite identical, this cannot be the cause of the problem.

Just have a look at the product after speckle filtering. Is the gap already there?

You can also retrieve Sentinel-1 data from here:

This is just radiometric and speckle filtered. No gap, but not in the right place

What happens when you apply Range Doppler Terrain Correction using GETASSE30 as DEM and Stereographic South Pole projection?

I tried it again with the entire image and now have a similar pattern.

It is maybe caused by the 180 degree border (date line).


We recently had a similar problem: About single polarization and dual polarization SLC interferometry

What worked for me is the Geolocation Grid ellipsoid correction

Tried the Geolocation grid ellipsoid correction before on other images. It makes a mess

Does the date-line cross the image? If yes, we have more than one open ticket about issues related to that I think.

I guess so, yes.

@jun_lu @lveci @marpet this could be related to our known issues around the 180 meridian.

Is this issue newer or established? I’m basing my work off a process that someone did for this area in 2017-18 and she apparently didn’t have problems.

What Map projection did you use when you ran TC and GG? Thanks

I used Stereographic South Pole

I think the problem was caused by that the product crosses the 180th meridian. Because of that, part of the geocoding of the product is incorrect which leads to the artifacts in the Terrain Corrected image.

This is a known issue and has not been fixed. Post of similar problem can be found at Terrain corrected S1 data crossing the antimeridian are shifted into the Western Hemisphere. The issue has been tracked by ticket

If you can create a subset of the image and make sure it does not cross the 180th meridian, then the processing result should be fine

That is possible. However, I spoke with the person who has processed the images from the years before and some of 2019 and they did not have this problem. Communication is limited with them which is why they haven’t been able to help me resolve this.
That being said: I don’t think there is an issue with the image but potentially a setting in the software or a step that I am failing to take while working with the data. I have uninstalled and reinstalled SNAP software but still got the issue. I think there is something I am missing and I don’t know what!

We figured it out: it only occurs in the latest version (7) of the software. It does not have this problem in version 6.