Image with a resolution of 20x20 m

No no, also 2000x2000 pixels or other is ok.
Is correct the second photo?

In this mode there is a error.

Thank you so much

you first make it 20m in the multi-looking and then select 5m as an output in the Terrain Correction, that doesn’t make sense. If you want 5m leave out the multi-looking.

About the error: You need to enter the number 5 in the “Pixel spacing (m)” not in the field for degrees.

1 Like

Looks like you’ve chosen pixel spacing of 554731 metres, which is obviously incorrect.

Yes, I was wrong because pixel spacing represents how much area each pixel covers, while resolution indicates the smallest object you could pick out in an image.

My problem is that I don’t understand how to obtain resolution of 5-10 m.

I don’t use the multilook but imposed the value directly as in the screenshot, now is it right?

At the end I would like to get a picture similar to this

In rough terms you are correct.

Short answer: you cannot. The resolution of the data is what it is (depends on sensor properties) and changing the pixel size cannot improve it. You can set the pixel size to 1m if you want to, but that does not increase the resolution to that level.

1 Like

Please, could you explain to me how to get photos from the Sentinel-1’s GRD product?

Multillook or Terrain Correction?

Now I’m really confused.

Multilooking reduces both the resolution and pixel-size. Do terrain correction to the map projection of your liking and select a pixel-spacing of 10m (for example) and see if that works for you.


Which map projecton is correct? I don’t know the differences.

Thank you very much.

both are correct. One is based on degrees, the other on meters.

1 Like

Excuse me for my many questions, I’m learning thanks to you.

I took this photo

with two steps in the screenshoots:

What is exactly the resolution of my image?

I know the pixel spacing of 10 m but I realized that resolution and pixel spacing are different, in fact this topic confirms it

I have some Tandem-x images that they have different dimensions. You can see the dimension of one of them in below:
dimension: 9659*6081

  1. I want to put whole images in same resolution and dimensions. I know for changing dimension I should use ‘subset’ option but how about resolution? Shall I use ‘resampling’ or ‘multilinking’?
    Is there any differences between both usages?
  2. I want to know what the resolution of my image is before changing resolution. How it is possible?
    Actually, I opened ‘resampling’ and then I choose ‘by pixel resolution’ but I do not know why it is zero!!!

you can do this easier by coregistration of all images. If you select a master image, its resolution and extent is used for all salve images. You can define the resampling technique and what should be done with areas which aren’t covered by all images (minimum extent, master extent, maximum extent).

Thanks for the help @ABraun
I have some more questions, please look at them:

  1. As you told me, I used co-registration and I put three images (1. backscatter, 2. coherence 3.phase) but I do not know why in the result, I do not have phase image?

You can see my steps in below:

  1. Productset reader; I put three images here but type, acquition, track and orbit are empty. I used these data before for classification and I had same issue ( I mean type, acquition, track and orbit were empty) but the classification worked and I thought it was not important, so I do not think so this is a problem.

  2. Creat stsack; I leave this box like below but I do not know what is the meaning with ‘output extent’ here.

  3. Cross-correlation; I leave this box like below but I do not know what is the meaning with its options here.

  4. Wrap; I leave this box like below but I do not know what is the meaning with its options here.

Another important thing;
5. How can I see what is the resolution of my original data? As I mentioned that before when I went to re-sampling part, the resolution part was zero. Why?

I have one question regarding this answer that you (@ABraun ) gave. Sorry if I misunderstand.
As I look at SNAP software, there are several ways for changing resolution;

  1. Using multi look option in SNAP
  2. using re-sampling option in SNAP
  3. using Range Doppler terrain correction option in SNAP
    So why you mentioned that we should use first, multi looking and then the RD Terrain Correction???!!


if you already performed RD terrain correction the better method for offset estimation is “product geolocation” instead of “orbit”

Each of these steps changes the resolution but they still perform different tasks:

  1. Multi-looking generates square pixels out of slant range geometries in the first place, no resampling technique applied.
  2. Re-sampling only changes the resolution to a given pixel-size.
  3. Terrain Correction adjusts the image to local topographic conditions, thereby using resampling as well.

It totally depends on what you want to do with your data. There is no “standard” way of perparing SAR data for analyses. Sometimes multi-looking simply helps to see the image undistorted.

Hello all,

I know this topic is closed for over 2 years now, but I need to ask you this:

When I give the pixel size of 30 m in RD terrain correction for my SAR image, spatial resolution is set to 30 m. However, when I subset (Clip) my image in Arcmap according to the shapefile, if I want to make the same rows and columns as my Landsat image (Subset from same shapefile), pixel size changes to 30.5 and 30.9. Pixel size of Landsat is 30 m. Can someone please tell me why this happens and how can I prevent it?

Thank you for help!

I’d say this depends on how ArcMap treats pixels which partly lie outside the shapefile. You can check in the processing environments if you find some setting which indicate that resampling is involved.

If you want to adjust Sentinel-1 and Landsat-8 to have the same pixel sizes and numbers, you can use the collocation tool with the one of smaller coverage as the master and the other as the slave.


Thank you for help!

Just letting you and everyone know that re-sampling twice worked.