Import button not working

Hello all

Recently, I have encountered a problem with import button in SNAP: whenever I click a specific format inside the ‘import’ button, the browse window does not appear.
As a solution re-installed SNAP. With re-installed version the import button worked only once and then stopped working.

Any suggestions on how to fix this problem?

P.S. I am using windows 10.

Hi gupta353,
I haven’t heard about this error before.
Which format do you watt to import or does it happen for all formats?
Do you have the latest SNAP version, including all the updates installed?

Could you send attach the log file?
You can find it by selecting from the menu Help / Show Log Directory. Make sure to reproduce the error first and then attach the messages.log file.


This isn’t a common problem, so it would be good to mention any unusual aspects of your configuration. Where are your data files (on a network drive, the system “drive”, USB drive, etc.)?

If you are using Windows, you should mention the Windows version whether you use “OneDrive”, and which AV software you have. Some AV products move “suspect” files to quarantine or block suspect applications, so you should check your AV’s logs.

On Windows 10 (Pro and Enterprise) there have been problems (perhaps related to a recent update) with app windows taking as long as 20 minutes to load, so you should try extreme patience and watch for “Not responding” messages. I had this problem but it seems to have ended with an unscheduled update a few days ago. The problem seems to be related to a “recent files” list where some files were on a server that was off-line.

For linux, please mention your distribution and version.

For macOS please mention your version.

For both linux and macOS: If you have tried installing, updating, or running snap using the “sudo” command (e.g., with “root” privileges) you may have file permission problems.

If you can create a new “snaptest” user and do a fresh install of SNAP as that user it could help pin down the problem.

Marcos, It is not working with any format. Ans I installed 7.0 SNAP recently, after this problem occurred, along with some updates. Unfortunately, no error message pops up, I am attaching the log-file obtained after clicking on one of the formats in import menu.messages.log (68.5 KB)

gnwiii, I am using windows 10. I have been using snap on this OS for 3-4 months now. This problem is recent. I will do ‘snaptest’ user thing, post the results.

In the log is an indicator for the problem visible:
An exception occurs:

java.nio.file.InvalidPathException: Illegal character [?] in path at index 2: \\?\D:\Research\EPA_Project\Lake_Erie_HAB\Data\remote_sensing_data\MERIS_RR\BDP_meris-ds_MER_RR__2P_000010\EN1_MDSI_MER_RR__2P_20110503T154936_20110503T163329_047971_0112_20190129T100542_0100\ENV_ME_2_RRG____20110503T154936_20110503T163329_________________2632_102_112______DSI_R_NT____.SEN3
	at sun.nio.fs.WindowsPathParser.nextSlash(Unknown Source)
	at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
	at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
	at sun.nio.fs.WindowsPath.parse(Unknown Source)
	at sun.nio.fs.WindowsFileSystem.getPath(Unknown Source)
	at org.esa.snap.vfs.VFS.get(
	at org.esa.snap.vfs.NioPaths.get(
	at org.esa.snap.rcp.actions.file.ProductOpener.openProduct(
	at org.esa.snap.rcp.actions.file.ImportProductAction.actionPerformed(

Strange! Where is this illegal character coming from?

There were similar but different reports before:

@oana_hogoiu Maybe you have an idea what’s going wrong?

Thank you. I re-installed SNAP by choosing to delete all the previous data but the same problem persists.

Did you also deleted
C:\Users[username]\AppData\Roaming\SNAP (or C:\Users[username]\AppData\Local\SNAP )
(in the post mentioned above the user solved this by deleting all SNAP directories and then a fresh SNAP install)

Thanks oana_hogoiu. I will quickly test this solution and post the results.

An update:
As suggested by gnwiii, ‘waiting for the import button to work’ has not solved the problem yet, and, unfortunately my system does not allow me to create a user (probably because I have a home addition).

All: I have been able to understand the error a little better now. This problem occurs only when open the ‘MERIS LEVEL 1 sentinel-3 product format(*.xml)’. As soon as I open a file in this format, the import button stops working.

oana_hogoiu. I noticed that I already deleted the files you mentioned.

Many Windows users have encountered very long delays opening applications. There are reports that the issue is associated with Windows Defender. I encountered this trying to start an application where the list of recent files included a file on a network drive that was no longer available (the “solution” was to clear the list using the registry editor, but I think SNAP stores the list outside the registry, so the easy way to check for this is to try a new user account).

Many people have had problems finding the place to add users in Home Edition: Windows 10 Home Edition Issue with Local Users and Groups - not able to add has over 1000 user with the problem.

Thank you gnwiii.