Install SNAPHU using Cygwin

But I couldn’t even install snaphu. I am talking about installation, not working in snaphu.

please read carefully - snaphu 1.4.2. is already installed when you download it. “Compiled” means that windows can use it as it is.

Unfortunatelly, it doesn’t work. I tried on two devices but it doesn’t open.

open the command window like described here: and type snaphu

Can i perform unwarping using,windows 10,64bit,8 GB?pleas guide me how i can do it??:disappointed::disappointed:

please stop cross-posting the same question over different topics and have a look at the answers posted here: SNAPHU Unwrapping

There is a video and links to further information.

Thank you very much @ABraun , I installed snaphu following your instructions. Everything worked perfectly.

According to Dr. Braun’s i try the first step and apparently I did not create a folder. What did I miss and what can I do?

you no longer need to compile snaphu - the latest version is stand-alone:

Good evening Dr. Braun. I would like to ask you something. I have the displacement bands for each pair i have been processing. Is there a way to “merge” all the results in one and create a map of it?

you can terrain correct both of them and create a stack.

It might sound funny but I am a little confused right now. They are already terrain corrected and I just created a stack. Now I would like to export the stack result to arc map. I can do that right?

Yes, if the stack looks fine you can export the raster layers.

Dear ABraun
I have few doubts regarding your tutorial on using Snaphu in windows.

  1. I have downloaded the latest version from this link , however I am not able to find snaphu.exe in the bin folder even after unzipping it.
  2. Alternatively, I have downloaded cygwin and followed the steps as mentioned in your tutorial-Installation_SNAPHU_English_ABraun.pdf, but I got an error when I tried to execute the ‘make install’ command.

Kindly help me resolve the issue. Thank you)

It should be in the bin folder, sometimes Windows doesn’t display file extensions, it might just be snaphu.

I don’t recommend compiling it since version 2.4

Thank you. I typed snaphu in my command shell after which I was able to view the list of parameters. After that I copy pasted snaphu -f snaphu.conf Phase_ifg_HH_02Jan2007_05Jul2007.snaphu.img 9344 from snaphu.conf created in the SNAPHU sub folder of my filtered IFG folder in my D drive. However, I am facing ‘unable to read config file’ error in my command shell.
Please see the image below and kindly let me know where I am going wrong.

and I am also getting the following error ‘can’t open file’ .

these are my products. image

Kindly suggest to help me solve this problem

you need to navigate into the folder where your data was exported or start your shell directly there.

Thank you dear ABraun for your suggestion. I am running the process of phase unwrapping now.

My phase unwrapping process has begun 4 hours ago but it’s still stuck in unwrapping tile at column 1 as shown in the pic. Please let me know if it’s proceeding correctly but may require time.