Installation on Linux (Ubuntu)


I just installed Snap on Ubuntu and encountered a quite annoying problem.

By default, Snap wants to install under /home/snap and therefore checks if there is an old installation there.

The install tool told me that it found an older installation and recommended to suppress the files. I guess this is due to the fact that it found a /home/snap directory. I therefore went on, and the whole /home/snap folder got deleted.

The problem is that, on Ubuntu, this folder also contains ALL the config files for ALL applications that have been installed through the package manager system snap (Snaps in Ubuntu Core | Ubuntu). I therefore lost all the settings of my Snap applications.

It’s only bad luck that snap (the Sentinel toolbox) has the same name as Snap (the package management tool). But maybe the install tool can be sligthly modified in order to recognize what, under /home/snap, really belongs to the Sentinel toolbox?

Many thanks in advance! Cheers

This is why we should have backups. I think you mean $HOME/snap. Others have already reported this conflict and it is easily avoided by installing ESA SNAP to a different directory name.

The number of linux applications/packages only increases over time, so such name conflicts are becoming more common (not only in linux, How many “Stéphane’s” do you know? For free, open-source software, developer time is a scarce resource. This means users should not expect the level of polished packaging you get with popular commercial packages or a brand new Mercedes. SNAP is more like a car that has had multiple owners and haphazard maintenance – you have to expect and be prepared for breakdowns.

Thanks for your reply!

I actually do have backups, and could recover easily. But this will not be the case for every user. And I don’t see it as a “normal” behaviour for a software to erase data from other applications.

I actually installed Snap in another folder (namely /home/steph/Softs/ESAToolboxes/SentinelToolbox/esa-snap ) but deleting the previous settings actually happen before you can indicate the new installation directory.

Finally, I am fully with you on the fact that I cannot expect a fully polished tool and that the developers cannot take into account every single edge case. But I would argue that “snap”, in the Linux world, is far from an edge-case, and that the installation process could (should?) identify the actual setting files instead of assuming that everything under $HOME/snap concerns exclusively snap.

That being said, I of course fully understand that this is by far not a priority issue. Maybe an explicit word of warning, either on the DL page or in the installation windows, would avoid that future users experience the same issue.

If I had the dev skills, I’d be more than happy to propose a patch for this. Unfortunately this is way outside of my skillset.

Thanks a lot to all contributors who provide us with such an amazing toolbox!

I tried this , /home/steph/Softs/ESAToolboxes/SentinelToolbox/esa-snap but deleting the previous settings actually happen before you can indicate the new installation directory. Finally I have used Kali and it is solved. You can check other ubuntu alternatives for installing it.

The bin folder and the gpt file don’t seem to exist even though SNAP is functioning

Isn’t this the folder where the program is installed? Can you advice me what I can do to solve this problem ? Because the gpt file is required at some step within the snap2stamps workflow

Your image shows ~/.snap which is the location of user files. When you install ESA SNAP you are asked to chose a location for the install. The installation default is ~/snap (but note that Ubuntu has a completely different program called SNAP – when you install ESA SNAP you should chose a different name for the installation folder, such as ~/esa_snap). If you don’t remember the ESA SNAP install directory or are using an installation provided by someone else, you can determine the location of the bin directory from messages.log, whose location can be found using the Help Menu of the ESA SNAP GUI to “Show Log Directory”.

1 Like

yes I understand now, I have confused the installation of ESA SNAP with Ubuntu’s built-in SNAP, reinstalling ESA SNAP in a different location has solved the problem. Thank you very much sir