Installing StaMPS in windows

Hello!

I’ve been following a RUS tutorial and I can’t do one step RUS webinar: SNAP2StaMPS – Data preparation for StaMPS PSI processing with SNAP - HAZA09 - YouTube.

I’ve download the StaMPS folder and I can’t manage to install it. Should I set it to an Environment Variable as SNAPHU ?

I’ve been following this tutorial as well : Using StaMPS/MTI for PSI Analysis – Part 1: Installation and Setup | GIS-Blog.com but maybe i’m not too familiar with the InSAR/command line “language”. Do I need to have linux?

Folder with StaMPS files: Screenshot - 6f2390504fc2d2edb5b671a1d22be54f - Gyazo

Command line not recognizing StaMPS: Screenshot - 404196f03852d59923e844c4c771653c - Gyazo

Thank you!

Linux prevents many errors, so I recommend using it for StaMPS, although people have been successful in using it under Windows as well.
You need to have the stamps binaries compiled (using the make install command as documented in the tutorial you listed) and then configure the path variables to recognize all folders containing commands (under “Configuration”).

Alright thanks! I guess my problem is that I can’t use the “make” command in windows by default, i have to use a work around or something like that

I’ve managed to install “Chocolatey” which enables the make.exe command in windows and i think it’s kind of working, but i still can’t .exe stamps. I used the make command on the “src” folder where “Makefile” file is.

Try using WSL for Windows. This emulates a Linux environment on Windows. I haven’t tried it myself though.

please,can you help me to install matlab on ubuntu on wsl
I have ubuntu16.04 on windows and i want to install matlab r2018a in ubuntu but i can not please help .
root@DESKTOP-SMROJT0:/mnt/d/R2018a# ls
activate.ini install licenses ui
archives installer_input.txt patents.txt version.txt
bin install_guide.pdf readme.txt
etc java sys
help license_agreement.txt trademarks.txt
root@DESKTOP-SMROJT0:/mnt/d/R2018a# sudo ./install
Preparing installation files …
Installing …
Finished
root@DESKTOP-SMROJT0:/mnt/d/R2018a#
the installer does not launch and MATLAB is not installed,installer window does not open
I have tried ;
root@DESKTOP-SMROJT0:/root/softwares/R2018a# xhost +SI:localuser:root
localuser:root being added to access control list
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 109 (X_ChangeHosts)
Value in failed request: 0xe
Serial number of failed request: 7
Current serial number in output stream: 9