Interefometry with alos can't read phase

hey everyone
I used ALOS images to create an interferogram everything went well until the snaphu import the error is can’t read the uwnraped phase the other one it says that


the message goes away once you proceed to the third tab and select the hdr file of the unwrapped phase (after processing the img with snaphu).

thanks, i did, but the final result was chaotic snaphu took 5 hours ( minutes with sentinel ) it’s like it doesn’t work with snap.
results were illogical at all
thanks in advance
the time was between July the 20th and September the fourth

But this is a different problem and indicates that the interferogram quality is insufficient or the tile size should be adjusted.
Can you please share a screenshot of the interferogram?



That is a zero-coherence interferogram that contains only noise, which cannot be meaningfully unwrapped. Either the area is totally decorrelated (ocean?) or something went wrong in the earlier processing steps.

it’s on land

Please test with an RGB image if the coregistration was successful.

it wasn’t succesful

coherence very low

Please delete the stack and run the coregistration again with a higher number of GCPs.

You can check if the images are aligned as shown in this tutorial InSAR Displacement mapping with ERS data (pages 10-11)

1 Like


the statistical errors look alright, but the perpendicular baseline of 700 m is rather large for displacement mapping.

Source: InSAR Principles: Guidelines for SAR Interferometry Processing and Interpretation (ESA TM-19) Part B

How does the RGB look like?

final result

Congrats for coherence - has the flat-earth phase been removed?

in which phase should i do it ?

looks better! The interferogram operator contains a checkbox to include the removal of the flat earth phase, please select it.

I did it but no meaningful result was obtained (the unwrapped phase look the same), I was interested in the L band because of its penetrative capacities, but unfortunately, I see that its products aren’t good enough.

the inteferogram doesn’t look too bad actually, are you sure that the topographic phase has been removed correctly? You can skip this option during the interferogram formation step and apply it as a separate module (same menu) which allows you to put the topographic phase into a separate band so you can visually inspect it.