Interferogram Dimension Error While Unwrapping with Snaphu

I am trying to create a DEM with using 2 Sentinel-1 images. After creating interferogram, I tried to unwrap it using Snaphu. In the beginning of the process, it ended up with an error like this:

snaphu v1.4.2
27 parameters input from file snaphu.conf (84 lines total)
Logging run-time parameters to file snaphu.log
one or more interferogram dimensions too large

The data I am using is the data I obtained from Sentinel interferometry tutorial. But somehow it didn’t work for me. Does this mean I should subset and make the interferogram smaller? Is it possible? If it is, how is it supposed to be done?

This is how it looks.

Thank you.

I’m not sure if the error indicates that the image is too large in general. But it would be worth a try:

  1. zoom to a region of higher interest, maybe 25% of your image or less
  2. right-click “spatial subset from view” and save the product
  3. run the export again and try to perform snaphu with the smaller image

Let’s see if this solves the error from a technical side.

It started to proceed properly, thank you for the help. But it got cut off in between due to the error “out of memory”.

The virtual memory tool I am using is Cygwin. I am supposed to increase the memory for Cygwin I guess. Did a search for it but couldn’t find something helpful. Do you know how it can be done?

Thank you very much again.

it’s something :slight_smile:

I heaven’t tried it myself but maybe this helps:

I tried plenty of commands in the links and on other websites, but ended up with error again.

Thank you so much.

If you are using windows you could also run snaphu.exe directly from the cmd shell

I described it here:

page 6.
The location of snaphu.exe must be in your system’s PATH variable.