Interferogram Mosaic


#1

I am trying to create a mosaic from two fully processed Interferograms. I realized the event I am interested in is right in the middle of two subswaths. However, the resulting product is not right. Is it possible to mosaic two fully-processed interferograms in SNAP? If not, what steps can I take to create this product? I have included screenshots for reference.






#2

have you also tried the other tool underRadar > Geometric > SAR Mosaic?


#3

Thanks! That worked like a charm. The only problem I have no is that I can’t unwrap the mosaic. I will try to unwrap each subswath separately and mosaic after.


#4

If those are two sub-swaths in the same S1 product, the function ‘TOPSAR-Merge’ (in graphs) or ‘S-1 TOPS Merge’ (in the menus) is meant to do what you need.
SNAP comes with graph examples (‘TOPSAR Coreg Interferogram IW All Swaths.xml’, maybe others) that will guide you on the steps needed.


#5

Unfortunately one is S1A and the other, S1B. They have the same footprint, however. I’m new to SAR as well as SNAP so I’m only aware of the tools in the online tutorials.


#6

You can do interferometric analysis so long as they have the same relative orbit number (look in the metadata for this parameter), even if one is S1A and the other S1B. If the two products have the same footprint, then they have the same relative orbit number.


#7

I try to unwrap all swaths from sentinel-1 image. First I used the graph “TOPSAR Coreg Interferogram IW All Swaths”, then topographic phase removal, goldstein filter.

Then export to snaphu with 10x10 col-row and 15 processors, but when snaphu try to Assembling Tiles, fails with this message

  0 [main] snaphu 12260 cygwin_exception::open_stackdumpfile: Dumping stacktrace to snaphu.exe.stackdump

But, when I execute this process with only 1 swath, dont have any problem.


#8

Dear @pete16es
I have same fails error
(4 [main] snaphu 7800 cygwin_exception::open_stackdumpfile: Dumping stack trace to snaphu.exe.stackdump) after exhausted 12 hour from (7:00 p.m. to 7:00 a.m.) processing.
Did you find solution?


#9

Hi @Meelad_16777, regrettably I don’t find any solution yet. I try with a lot of combinations in the processing parameters in snaphu, and the result its the same. If you find a solution, please tell me.


#10

Hi @pete16es I use the Cygwin for helping unwrapping phase I got error (cc -O3
snaphu.c
snaphu_tile.o snaphu_solver.o snaphu_io.o snaphu_util.o snaphu_cost.o snaphu_cs2.o
-o …/bin/snaphu
-lm
cp …/bin/snaphu /usr/local/bin;
cp …/man/man1/snaphu.1 /usr/local/man/man1/
cp: cannot stat ‘…/man/man1/snaphu.1’: No such file or directory
Makefile:42: recipe for target ‘install’ failed
make: *** [install] Error 1
) when inter make install. So My Snaphu extended to 10-12 hour , then got stackdumpfile…
To its moment I can’t find solution.

Thank you for your reply.