Is Sen2Three no longer in development/support?

I’ve tried many times to run Sen2Three on old naming convention prods (Sen2Cor’ized), and many times I get various errors, and I have no clue about them. I’ve seen sen2three topics (, but I see, that there is no helpful answers, despite that other topics (about s2tbx) are getting helpful answers very soon.

I want to understand:

  1. Has the Sen2Three been tested at all before releasing its versions?
  2. Is Sen2Three no longer in support/development? (the latest release was in year 2017! no support of new naming convention prods)

If Sen2Three is no longer in support or development, the official announce will be good, because, I think, no one of Sen2Three users want to burn their time to understand, how they can successfully run the promisingfully powerful tool.

Dear Robert,

Please be informed that Sen2Three 1.1.0 supports the processing of Sentinel 2A and 2B Level 2a input products (PSD version 14.2) and is compatible to Sen2Cor Version 2.4.0 (the actual version of Sen2Cor is 2.8).
In addition to this, the development and maintenance of the new Sen2Three version is planned to start in the near future (within 2021).

Best regards,

1 Like

Source code of sen2three-1.2.0 ( works fine processing S2L2A products.

I only get errors loading them in SNAP 8.0:
Error: No valid tiles associated to product [MTD_MSIL03.xml]

But the [MTD_MSIL03.xml] file looks right, I do not know if the problem becomes from SNAP

1 Like

Please, tell me, on what OS you have installed s2t, and how you’re running it?

For me, I’ve unsuccessfully ran S2T on Google Cloud Platform data, that was Sen2Cor’ized (both 2.5.5 and 2.4.0). I also have tried the SciHub data.

It would be good, if you write some manual about it.

I use Windows 10, but It should run in another OS.

I installed sen2three 1.1.0 as usual and I have replaced all content in the folder of python 2.7 where it is installed with files of this new release.