Issue with --nogui start option; snappy config

I wanted to add a new start option to SNAP. It should only be used from the command line. So, the additional options –nogui and –nosplash should be specified along with the new option.
Unfortunately using the –nogui option leads to an error. At least from the development environment.

SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor org.esa.snap.rcp.SnapApp$StartOp
java.util.ServiceConfigurationError: javax.imageio.spi.ImageOutputStreamSpi: Provider not found
	at java.base/
	at java.base/java.util.ServiceLoader$LazyClassPathLookupIterator.nextProviderClass(
	at java.base/java.util.ServiceLoader$LazyClassPathLookupIterator.hasNextService(
	at java.base/java.util.ServiceLoader$LazyClassPathLookupIterator.hasNext(
	at java.base/java.util.ServiceLoader$2.hasNext(
	at java.base/java.util.ServiceLoader$3.hasNext(
	at java.desktop/javax.imageio.spi.IIORegistry.registerApplicationClasspathSpis(
	at java.desktop/javax.imageio.spi.IIORegistry.<init>(
	at java.desktop/javax.imageio.spi.IIORegistry.getDefaultInstance(
	at org.esa.snap.rcp.SnapApp.initImageIO(
	at org.esa.snap.rcp.SnapApp$
	at org.openide.util.RequestProcessor$
	at org.netbeans.modules.openide.util.GlobalLookup.execute(
	at org.openide.util.lookup.Lookups.executeWith(
[catch] at org.openide.util.RequestProcessor$

It seems this is not due to my new option but a more general problem in SNAP.
When I try to invoke snappy configuration, I get the same error. The option is executed anyway, but it might indicate an issue with the SNAP startup configuration.

My run parameters as xml file from Intellij IDEA: (1.5 KB)

If I remove –nogui from the parameters, it runs without the exception, but also SNAP Desktop starts.

Not a severe issue, but I thought I report it.

JIRA ticket SNAP-3649 created.

1 Like