Issue with S3 Subsetting

I have a strange issue here. I run a graph that subsets S3 imagery to a specific footprint within the S3 tile, and then goes on to Rayleigh correct the resulting subset. This has worked fine with thousands of tiles in different locations. I have one location, that fails to produce Rayleigh output, always throwing:

Executing processing graph
INFO: org.hsqldb.persist.Logger: dataFileCache open start
22%.33%.45%…55%…65%.90% done.
at org.esa.snap.core.gpf.graph.GraphProcessor$GPFImagingListener.errorOccurred(

Caused by: java.lang.NullPointerException
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(

I had a colleague verify that he was experiencing the same, and we’re both using SNAP 9.0.1.

I then manually processed this in SNAP. The subset produced in SNAP is markedly different that the one produced by the graph. It is taller, with the left and right sides chopped off (I suspect that this is due to the different way geocoordinates are provided to SNAP (N/E/S/W) vs the graph which uses a POLYGON):

The left is the graph produced one, and the right is the SNAP produced one. It appears that SNAP more accurately depicts the footprint, but nevertheless the subset produced by the graph is valid, and below is a masked true-colour image produced with the subset done by the graph (it has been reprojected to WGS84):

The problem now is the Rayleigh correction. The graph produced subset fails, whereas the SNAP produced subset succeeds.

Note. I ran a test, reverting to SNAP 8, and the subset created by the graph is fine.

@marpet have you been able to look into this. While we have a workaround - using SNAP 8 - we may find additional benefit using SNAP 9.


right know I have no idea what going wrong here.
Can you provide the full stack tace and also the data product where this error occurs. At least the name of the product, so we can download it.