Java s3toolbox

I am trying to install s3tbx in java so i can write scripts from there.

I follow the instructions provided https://github.com/senbox-org/s3tbx.

Can somebody how i can Import the pom.xml files of snap-engine, snap-desktop and s3tbx as modules?

Moreover i ge some build faulures when trying to install Sentinel-3 Toolbox (provided screenshot).

Any ideas?

It seems that the modules of snap-engine and snap desktop are not properly deployed to the maven repository by the build system. @MartinoF can you have look?
Meanwhile I deploy them manually.

I’m not sure how you want to import the pom files of snap-engine and snap-desktop.
But a brief description how to build S3TBX is given in the README.md).
Have you first build engine and desktop?

More explanation can be found in the wiki:
SNAP development - SNAP Wiki

Hi Marco,

I checked on the nexus server and to me seems fine, the s3tbx-meris-ops 9.0.0-SNAPSHOT is on the server (both nbm and jar) but I already experienced strange problems with nexus and the snapshot version packages so it could be related. In any case I manually started a fresh build and deploy of the s3tbx on the CI just in case.
Let me know if you experience any new problem.

Cheers,
Martino

I think it is not the s3tbx module which is missing, but the snap modules.
I have already started a manual deploy

I also checked the snap-engine modules and also seemed to be correctly deployed (last upload from today), so does not seems a problem in the deployment.


Let’s see if the new deployment will fix the issue.

1 Like

Okay, thanks for checking this.

Followed the instructions to install snpa engine however
i get the following errors (screenshot)

Any ideas?

I’m sorry to hear this.
Further up in the log it should be stated which test failed. Could you look this up?
In general it should work. The tests pass on Travis CI and on our internal build server.
Also locally it is working:

It fails at [INFO] Ceres Metadata handling Library … FAILURE [ 2.756 s].
Then the rest are skipped.

Could you run maven and write the log to a text file and attach it here?

mvn test > snap-logfile.txt

This would be helpful.

snap-logfile.txt (75.5 KB)

It seems that you are not using Java 8. This is still the preferred JDK for SNAP.
You use 11 or 12 or so, and the implementation of DOMImplementation has changed and this results in the error.
In the test an XML snippet is processed and the DOMImplementation adds the header:

<?xml version="1.0" encoding="UTF-16"?>

In Java 8 this as terminated by a line feed, in later version not anymore.
Thus, the code which should remove this header fails.

I’ve made the code more generic and it should now work also for the latest version. However, you should switch to Java 8. There are more issues like this.
For the next release we will see if we can update to a recent Java version.

Actually if i print out the java version i see this
java version “1.8.0_261”
Java™ SE Runtime Environment (build 1.8.0_261-b12)
Java HotSpot™ 64-Bit Server VM (build 25.261-b12, mixed mode)

which is from Java 8 if i am not correct?

I pulled again from git snap engine but still it fails to install

Try mvn -v
This should show you which version is used by maven.

I’ve tried with
1.8.0_242, vendor: AdoptOpenJDK
and some version12 from OpenJDK.

You are using still the Oracle JDK. We don’t use it anymore since the license change Oracle did in April 2019. And the last version we test was, I think, jdk1.8.0_202. So, there might be a difference too.

That the test is still not working for you is surprising.

tried it and get
Apache Maven 3.5.3 (3383c37e1f9e9b3bc3df5050c29c8aff9f295297; 2018-02-24T21:49:05+02:00)
Maven home: C:\Program Files\apache-maven-3.5.3\bin…
Java version: 1.8.0_261, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.8.0_261\jre
Default locale: en_US, platform encoding: Cp1253
OS name: “windows 10”, version: “10.0”, arch: “amd64”, family: “windows”