L1C user product direction must match the following mast

I am trying to atmospherically correct L1C data to L2A. I have installed sen2cor and now when I select an image I am getting the following error:

L1C user product directory must match the following mask: S2?_MSIL1C*.SAFE
but is: L1C_T14RNU_A009690_20170430T172229
Finished tool execution in 12 seconds

I am very confused and do not know what to do. I have redownloaded the data and placed it in another folder with less sub folders but I am still getting the same error.

Thank you

1 Like

The message indicates that the folder structure is different than expected. Where did you download the data?
Actually, you just extract the downloaded zip file but leave the folder as it is. Don’t rename the top folder and select the MTLD file directly in the main folder.

That worked that you so much!!

Hello ABraun,

I have the same problem. I want to apply sen2cor on a L1C file I imported to SNAP but it gives out the same message Hannah provided. I don’t know where sen2cor should be looking for the data. Can you help me out? Thanks

The error message is quite clear - did you rename the top folder?

I understand what it means, but I don’t know where to put the data.
I installed SNAP in C: along with the sen2cor plugins (v255 and v280). v280 doesn’t work, so I am resorting to v255. The corresponding folders are:


My data is in a folder I made in D: for sentinel 2 data I will be analysing. I loaded a L1C into SNAP and tried processing it to a L2A and it gave out that message.

L1C user product directory must match the following mask: S2?_MSIL1C.SAFE*
but is: S2A_MSIL1C_20170614T112111_N0205_R037_T29TPF_20170614T112422.zip
Finished tool execution in 1 seconds

Now, you said the data should be in a folder, unzipped, but I don’t know where. Also, SNAP only loads the data when it is .zip.

Is your data still zipped?

I have both. Zipped and unzipped. In the folder where this file is in, I can only load the zipped one.

Can you please specify? Maybe with a screenshot?

When I mean load, I mean if I click on the zipped file and do “Open”, SNAP loads/selects it. If I do “Open” on the unzipped folder, it just goes to the next folder under it, and so on.


So, I figured it out, apparently. I had to select the MTD_MSIL1C.xml file within the unzipped product .SAFE folder in order for it to work.

This using the sen2cor v255. I still haven’t tried with v280 yet. Perhaps it is the same issue.